Issue 122709 - Change default size of application windows on Linux
Change default size of application windows on Linux
Status: VERIFIED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All Unix, all
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-09 15:06 UTC by Andre
Modified: 2013-07-19 09:29 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2013-07-09 15:06:42 UTC
The default sizes of application windows on Linux are almost square (when not fullscreen for Calc, Draw, Impress).  This does not work well with the new sidebar, which was designed for wide screen displays.

Change the default sizes to what is used on Mac: use 80% of width and height.
Comment 1 Andre 2013-07-09 15:08:52 UTC
Requesting release blocker flag because a better default size would greatly benefit the new sidebar feature.

The change is small and the probability for introducing regressions is small.  Only Linux (GTK module) is affected.
Comment 2 jsc 2013-07-10 07:29:01 UTC
grant showstopper flag
Comment 3 SVN Robot 2013-07-10 08:11:07 UTC
"af" committed SVN revision 1501668 into trunk:
122709: Set default size of application windows to 80% of the screen size.
Comment 4 Andre 2013-07-10 08:14:02 UTC
Modified GtkSalFrame::calcDefaultSiz() so that for screens with a width larger than 1024 the returned size is 80% of width and height of the screen size.
Comment 5 Ariel Constenla-Haile 2013-07-12 08:11:28 UTC
http://svn.apache.org/viewvc/openoffice/trunk/main/vcl/unx/gtk/window/gtkframe.cxx?view=markup&pathrev=1501668#l1248

 if (true || aScreenSize.Width() <= 1024)

this looks like a typo, it evaluates always to true, so the first branch is chosen, and the new code with the fix is never executed.
Comment 6 Andre 2013-07-12 08:20:01 UTC
Yes, I used the "true ||" part for preparing screen shots.  Fortunately this is harmless.  It just means that the old sizes are still used.
Comment 7 SVN Robot 2013-07-12 08:25:26 UTC
"af" committed SVN revision 1502467 into trunk:
122709: Removed debug code.
Comment 8 Ariel Constenla-Haile 2013-07-12 08:47:52 UTC
@jsc: unless you plan another release candidate for this fix, shouldn't release blocker status be removed - as verification in the current RC will fail?
Comment 9 jsc 2013-07-12 08:55:44 UTC
yes, I changed it back to ?
Comment 10 SVN Robot 2013-07-16 13:03:12 UTC
"af" committed SVN revision 1503702 into trunk:
122709: Also test for small heights.
Comment 11 jsc 2013-07-16 13:06:39 UTC
grant showstopper flag again, was already planned for a potential respin and fix is available
Comment 12 SVN Robot 2013-07-16 13:09:48 UTC
"af" committed SVN revision 1503704 into branches/AOO400:
122709: Removed debug code and testing for small heights.
Comment 13 Andre 2013-07-16 13:12:48 UTC
Merged revisions r1502467 and r1503702 from trunk into the AOO400 branch.
The first removes the debug code (see comments 5 to 7), the second makes sure that the old hand crafted sizes are also used when the screen height is smaller than or equal to 768 pixels.

Status remains resolved/fixed.
Comment 14 fanyuzhen 2013-07-19 05:57:35 UTC
I check it on Ubuntu 32 bit, it has fullscreen for Writer, Impress, Calc and Draw
Comment 15 fanyuzhen 2013-07-19 09:29:39 UTC
I check it on RHEL 64bit, it has fullscreen for Writer, Impress, Calc and Draw