Issue 122635 - [sidebar] Truncated labels in Properties Panel (localization and scaling related)
[sidebar] Truncated labels in Properties Panel (localization and scaling rela...
Status: RESOLVED FIXED
Product: Calc
Classification: Application
Component: ui
4.0.0-dev
PC Windows 7
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
: 122651 122652 (view as issue list)
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-06-29 13:21 UTC by Regina Henschel
Modified: 2013-07-11 13:57 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+


Attachments
Screenshot showing the truncated labels (40.22 KB, image/png)
2013-06-29 13:21 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-06-29 13:21:53 UTC
Created attachment 80948 [details]
Screenshot showing the truncated labels

Several labels are truncated in the Properties panel in Calc. The label fields need to be wider or have a flexible width to allow longer words in non English languages.
Comment 1 Rainer Bielefeld 2013-06-29 16:18:33 UTC
More or less Reproducible with  "AOO 4.0.0-Dev – English UI / German locale [AOO400m2(Build:9701)  -  AOO400m2(Build:9701)  -  Rev. 1497734
Rev.1496828  2013-06-28]" on WIN7 Home Premium (64bit)", Common 4.0-dev User Profile 

I only see the problem with Scaling 80%, not with 100% or 130%. And seems ok with English UI (i did not test the very same revision).
Comment 2 Andre 2013-07-01 10:48:16 UTC
*** Issue 122651 has been marked as a duplicate of this issue. ***
Comment 3 Rainer Bielefeld 2013-07-01 11:29:14 UTC
@Oliver:
You already fixed that for Bug 122260, may be you can do the same job here?
Comment 4 Andre 2013-07-01 13:29:56 UTC
No crash or data loss but this is a bug of a major new feature that is visible to all users of certain languages directly after startup.
Comment 5 jsc 2013-07-01 14:03:27 UTC
set showstopper flag
Comment 6 Andrea Pescetti 2013-07-01 22:04:40 UTC
Italian has the same problem. If I understand correctly, this won't require that we fix strings in Pootle. If it does, feel free to ask.
Comment 7 Andre 2013-07-02 11:58:37 UTC
Working on this.
Comment 8 Andre 2013-07-05 08:54:06 UTC
I have added a simple grid layouter that manages some of the panels.  This should fix the truncated labels and also arrange controls on panels better when the sidebar is made wider or narrower than its default width.

The implementation of the layouter can be found in sfx2/source/sidebar/GridLayouter.cxx.
Comment 9 SVN Robot 2013-07-05 08:59:51 UTC
"af" committed SVN revision 1499949 into trunk:
122635: Add layouting to some sidebar panels.
Comment 10 Andre 2013-07-05 09:07:30 UTC
*** Issue 122652 has been marked as a duplicate of this issue. ***