Issue 122500 - Impossible to build with Visual C++ 2008 Express Edition
Impossible to build with Visual C++ 2008 Express Edition
Status: RESOLVED FIXED
Product: Build Tools
Classification: Code
Component: code
4.0.0-dev
All Windows, all
: P3 normal (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
: regression, release_blocker
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 18:10 UTC by Ariel Constenla-Haile
Modified: 2013-07-11 07:30 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+


Attachments
Build log (8.47 KB, text/plain)
2013-06-08 18:10 UTC, Ariel Constenla-Haile
no flags Details
lingucomponent log (4.37 KB, text/plain)
2013-06-09 16:16 UTC, Ariel Constenla-Haile
no flags Details
Build log (95.66 KB, text/plain)
2013-06-10 08:41 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Ariel Constenla-Haile 2013-06-08 18:10:50 UTC
Created attachment 80803 [details]
Build log

Configure with the option --without-stlport

Build breaks in sal:

C:/build/trunk/main/solver/400/wntmsci12.pro/inc/stl\hash_set(29) : fatal error C1083: Cannot open include file: '../../VC/include/unordered_set': No such file or directory

TR header are not included in the Express Edition.

There is a separate "Visual C++ 2008 Feature Pack" that comes with the headers, but it requires " Visual Studio 2008 Standard Edition", the Express Edition does not work.

http://blogs.msdn.com/b/vcblog/archive/2008/04/07/visual-c-2008-feature-pack-released.aspx
http://www.microsoft.com/en-us/download/details.aspx?id=6922

"System Requirements:
Supported Operating System
Windows Server 2003, Windows Vista, Windows XP
        Visual Studio: This Feature Pack is only supported on systems which have the English language (ENU) version of Visual Studio 2008 Standard Edition or above installed."


If you configure with stlport, the build breaks in lingucomponent.
So current trunk cannot be built with Visual C++ 2008 Express Edition
Comment 1 Ariel Constenla-Haile 2013-06-08 18:12:14 UTC
(In reply to Ariel Constenla-Haile from comment #0)
> 
> TR header are not included in the Express Edition.

I meant TR1 headers:

"This feature pack also includes an implementation of TR1. Portions of TR1 are scheduled for adoption in the upcoming C++0x standard as the first major addition to the ISO 2003 standard C++ library. Our implementation includes a number of important features such as:

    Smart pointers

    Regular expression parsing

    New containers (tuple, array, unordered set, etc)

    Sophisticated random number generators

    Polymorphic function wrappers

    Type traits

    And more!"
Comment 2 Regina Henschel 2013-06-09 14:16:49 UTC
TR1 is in Visual Studio 2008 Service Pack 1 (SP1)
http://support.microsoft.com/kb/950264/en-us
http://www.microsoft.com/en-us/download/details.aspx?id=10986

I have updated the build instructions on http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step already February 2013 to point to the new location.
Comment 3 Ariel Constenla-Haile 2013-06-09 15:41:48 UTC
(In reply to Regina Henschel from comment #2)
> TR1 is in Visual Studio 2008 Service Pack 1 (SP1)
> http://support.microsoft.com/kb/950264/en-us
> http://www.microsoft.com/en-us/download/details.aspx?id=10986
> 
> I have updated the build instructions on
> http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/
> Step_by_step already February 2013 to point to the new location.

I already tried that, but I get:

Installation Requirements:

A compatible version of Visual Studio 2008 was not detected on the system. This update is designed for only the Microsoft Visual Studio 2008 (ENU) product family, and is not compatible with any Express editions.
Comment 4 Regina Henschel 2013-06-09 16:07:10 UTC
What did you try? I have installed "Visual Studio 2008 Service Pack 1" directly on Windows 7 32bit. I had not installed the older version of Visual Studio 2008 on that PC before. I had used the iso-image to install it.
Comment 5 Ariel Constenla-Haile 2013-06-09 16:16:26 UTC
Created attachment 80810 [details]
lingucomponent log

If you configure with stlport (still the default), the build breaks in lingucomponent.

Looks like libhunspell.lib is not linked to stlport
Comment 6 Ariel Constenla-Haile 2013-06-09 16:35:04 UTC
(In reply to Regina Henschel from comment #4)
> What did you try? 

http://www.microsoft.com/en-us/download/confirmation.aspx?id=10986
Comment 7 Ariel Constenla-Haile 2013-06-09 16:59:10 UTC
(In reply to Regina Henschel from comment #4)
> What did you try? I have installed "Visual Studio 2008 Service Pack 1"
> directly on Windows 7 32bit. I had not installed the older version of Visual
> Studio 2008 on that PC before. I had used the iso-image to install it.

IIRC I used the online installer. The license of the version I have states:

MICROSOFT SOFTWARE LICENSE TERMS
MICROSOFT VISUAL C++ 2008 EXPRESS EDITION, SERVICE PACK 1

that is Microsoft Visual C++ 2008 Express Edition, with SP1
Comment 8 Ariel Constenla-Haile 2013-06-10 08:38:46 UTC
I fixed the missing TR1 headers by repairing the installation (looks like a bug similar to the Standard Edition, where the order of installation may leave you with broken TR1 headers).

I leave this open, because a NON-pro build without stlport breaks now in extensions/source/ole

A pro build with stlport breaks in lingucomponent.
Comment 9 Ariel Constenla-Haile 2013-06-10 08:41:07 UTC
Created attachment 80813 [details]
Build log

Non-pro build without stlport broken in extensions/source/ole

Note: ATL libs and headers are from the Windows Driver SDK
Comment 10 Oliver-Rainer Wittmann 2013-06-10 11:36:21 UTC
Building on Windows without stlport requires as far as I know the SP1 variant of the MSVC 2008 compiler.

If you have Visual Studio 2008 professional installed you need to update to the corresponding SP1. Regina already provided the download link in her comment 2

If you have Visual Studio 2008 express installed you only need to update the corresponding SDK to the SP1 one which is found at 
http://www.microsoft.com/en-us/download/details.aspx?id=3138
Comment 11 Oliver-Rainer Wittmann 2013-06-10 11:42:09 UTC
Herbert already made some changes regarding non-pro builds - see his commits from 2013-06-06 on bug 122378. But there are further issues on non-pro builds with and without stlport.

I am currently working on these build problems.
Comment 12 Oliver-Rainer Wittmann 2013-06-12 15:09:42 UTC
fixed the build breakers in non-pro Windows build environments with and without stlport - see revision 1492233

Regina, Ariel:
Could you please update your environments and verify my fixes? Thx in advance.
Comment 13 Oliver-Rainer Wittmann 2013-06-14 08:07:50 UTC
Regina reports success on dev@o.a.o
--> resolving this issue as fixed
Comment 14 jsc 2013-07-02 12:23:58 UTC
grant showstopper flag, fixed alreay
Comment 15 hdu@apache.org 2013-07-11 07:30:45 UTC
Updated target to the release that will contain the fix.