Issue 122470 - [sidebar] Custom animation panel does not open from context menu
[sidebar] Custom animation panel does not open from context menu
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
: regression
: 122484 122538 (view as issue list)
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-06-05 08:21 UTC by Andre
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2013-06-05 08:21:04 UTC
1. Create a new Impress document.
2. Add a shape.
3. Right click on shape to open its context menu.
4. Click on the 'Custom Animation...' entry.

This should make the 'Custom Animation' panel in the sidebar visible but doesn't.
Comment 1 Andre 2013-06-05 08:22:12 UTC
This is a feature that I forgot to re-implement for the new sidebar.
Comment 2 Andre 2013-06-05 13:49:01 UTC
More examples of context menu entries or buttons that should show a certain panel in the sidebar but don't:

A)

1. Insert a table into an Impress document.
2. Click on the 'Table Design' button.

This should show the 'Table Design' panel in the 'Properties' deck.


B)

1. Create a new Impress document.
2. Right click on slide preview in slidesorter.
3. In the context menu click on 'Slide Transition'

This should show the 'Slide Transition' deck.

C)

1. Create a new Impress document.
2. Click on the 'Vanigator' button in the sidebar tab bar.
3. Right click on slide preview in slidesorter.
4. In the context menu click on 'Slide Layout'

This should show the 'Layouts' panel in the 'Properties' deck.
Comment 3 Andre 2013-06-05 15:41:04 UTC
Fixed all the places described above.  They still tried to switch panels in the old task pane.  Added the necessary functionality to the sfx2 sidebar implementation.
Comment 4 SVN Robot 2013-06-05 15:51:40 UTC
"af" committed SVN revision 1489925 into trunk:
122470: Fixed programmatic triggered switching of sidebar decks.
Comment 5 Andre 2013-06-06 07:07:15 UTC
*** Issue 122484 has been marked as a duplicate of this issue. ***
Comment 6 fanyuzhen 2013-06-24 07:01:43 UTC
*** Issue 122538 has been marked as a duplicate of this issue. ***
Comment 7 Andre 2013-06-24 07:57:47 UTC
*** Issue 122484 has been marked as a duplicate of this issue. ***