Issue 122437 - [sidebar] sidebar looses object context after open and close help in Draw
[sidebar] sidebar looses object context after open and close help in Draw
Status: RESOLVED FIXED
Product: Draw
Classification: Application
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-06-02 14:59 UTC by Regina Henschel
Modified: 2013-07-11 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-06-02 14:59:31 UTC
Start with Draw document.
Insert a shape.
Mark the shape. Notice, that you get the area panel for example in the properties deck.
Press F1 to open the help.
Close the help.
Notice, the sidebar shows only the dummy Insert panel in the properties deck although the shape is still marked.

Expected behavior: The sidebar shows still the shape relevant panels.

If you enable the Current Context panel, you see that the object context is empty. It should be Draw.

The problem is only in Draw, not in Writer, Calc, Impress.

BTW, if you open a Draw document, the object context (which should be DrawPage in that case) is missing too.
Comment 1 Andre 2013-06-03 08:17:08 UTC
Confirmed.  Taking over.
Comment 2 Andre 2013-06-03 10:39:09 UTC
Context notification in SlideSorterViewShell did not handle Draw documents.  Fixed that.
Comment 3 SVN Robot 2013-06-03 10:57:56 UTC
"af" committed SVN 0 into trunk:
122437: Fixed context notification for Draw documents.