Issue 122336 - [sidebar] Close button does not close sidebar window but docks it
[sidebar] Close button does not close sidebar window but docks it
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
PC Windows 7
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-18 11:15 UTC by Regina Henschel
Modified: 2013-07-11 13:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-05-18 11:15:25 UTC
Undock the sidebar window.
Click on the 'close' button in the title bar.
The sidebar window gets docked.

Expected behavior: The sidebar window is closed.

If you try to record a macro for this action, you will notice, that no action is recorded, but it should record a ".uno:Sidebar" with value "false".
Comment 1 Andre 2013-05-21 07:26:21 UTC
I was trying to recreate the behavior of Symphony where the closer closes the undocked deck but leaves the tab bar visible.  The intended behavior for AOO was to dock the sidebar but then only show the tab bar.
Comment 2 Regina Henschel 2013-05-21 08:11:02 UTC
The behavior with the docked window where the closer only closes the deck and keeps the tab bar open is correct. That is nice, please don't change that.

This issue is about the undocked sidebar window. Then there is not a selfmade closer, but the closer of the OS. For example I see the German tooltip "Schließen" using a German Windows7, although AOO is in English. In the undocked case it should follow this tooltip and close the window.
Comment 3 Regina Henschel 2013-05-21 08:29:19 UTC
Addition: If closing completely is not possible or not wanted, then it should be docked in the state, that only the tab bar is shown. Currently it docks with open deck.
Comment 4 SVN Robot 2013-05-21 09:51:33 UTC
"af" committed SVN revision 1484721 into trunk:
i122336: Show docked tab bar after closing undocked sidebar.
Comment 5 Andre 2013-05-21 09:54:33 UTC
Re comment3: That is what I meant.  Click on the system close of the undocked sidebar docks the sidebar and then closes just the deck.

It is of course possible to completely close the sidebar in this situation but I don't believe that frequent turning on and off the sidebar is a frequent use case.  I think switching between docked and undocked is much more probable.  If that assumption is true then leaving the docked tab bar visible is a better reaction to clicking the closer.

I fixed the behavior to the one described above and earlier (click the closer of the undocked sidebar docks then closes just the deck).  But I will leave this bug open for now to hear more arguments.
Comment 6 Andre 2013-05-22 09:50:57 UTC
Setting to fixed so that the result is tested.