Issue 122332 - [sidebar] Wrong context after focusing other application window
[sidebar] Wrong context after focusing other application window
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-17 14:20 UTC by Andre
Modified: 2013-07-11 13:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2013-05-17 14:20:36 UTC
How to reproduce:

1. Create Writer document
2. Create Impress document
2a. Create shape with text
2b. Put shape in text edit mode
3. Move focus to Writer document
   - by Alt-Tab on Windows
   - or by clicking on the Writer window.

After that the sidebar in the Impress window shows the layout property panel.

4. Move focus back to Impress document

The Impress sidebar still shows the layout property panel, even though the text is still in edit more.

Expected result: the Impress sidebar should show the panels for text editing: Text, Paragraph, Area, Line, Position and Size.
Comment 1 SVN Robot 2013-05-27 11:18:05 UTC
"af" committed SVN revision 1486578 into trunk:
122332: Don't change sidebar context when switching to other application window.
Comment 2 Andre 2013-05-27 11:18:51 UTC
The bug was caused by using SfxShell::Activate() and Deactivate() to notify context changes.  Deactivate() is called when an application window looses focus.

Reworked the context notification in sd and sc to fix this.