Issue 122321 - [sidebar] undock by dragging is no longer possible
[sidebar] undock by dragging is no longer possible
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
PC Windows 7
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-15 11:38 UTC by Regina Henschel
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-05-15 11:38:54 UTC
At least till snapshot 0 it was possible to undock this way:
Click on desk title and hold mouse button down.
Drag. You can see dotted lines.
Drop it at the new place.

That is a common behavior for docked windows.

This undocking by dragging is no longer possible in 1.
Comment 1 Rainer Bielefeld 2013-05-16 05:39:34 UTC
Effect is reproducible with server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev. 1482523 Rev.1482259 (2013-05-15)]" on WIN7 Home Premium (64bit)", own separate user profile

Undocking with drag and drop was possible with Rev.1476029 and  Rev. 1479897

Bug or feature? I think it's a bug.
Comment 2 Andre 2013-05-16 08:38:36 UTC
Definitely a bug.
Comment 3 Andre 2013-05-16 11:10:51 UTC
This was caused by my recent changes to support scroll wheels.  The new Deck::Notify() method did not pass other events to its super class.
Comment 4 SVN Robot 2013-05-16 11:19:17 UTC
"af" committed SVN 0 into trunk:
122321: Fix processing of scroll whell to not block other events.