Issue 122320 - [sidebar] deck has no closer when sidebar is not docked to right edge
[sidebar] deck has no closer when sidebar is not docked to right edge
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
PC Windows 7
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-15 11:28 UTC by Regina Henschel
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
'Topbar' without deck closers (163.19 KB, image/png)
2013-05-15 12:01 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-05-15 11:28:23 UTC
Undock the sidebar.
Drag it to the left edge of the document window and dock it there.
Notice, that the closer in the desk title no longer exists.
Comment 1 Rainer Bielefeld 2013-05-15 11:59:19 UTC
Reproducible with server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev. Rev. 1482523 Rev.1482259 (2013-05-15)]" on WIN7 Home Premium (64bit)", own separate user profile

Something I did not know until now: Sidebar also can be used as "Topbar" and "Bottombar", see screenshot. There 'Close-X' also is missing.
Comment 2 Rainer Bielefeld 2013-05-15 12:00:16 UTC
CONFIRMED due to comment before
Comment 3 Rainer Bielefeld 2013-05-15 12:01:10 UTC
Created attachment 80687 [details]
'Topbar' without deck closers

See my first comment
Comment 4 Andre 2013-05-16 08:52:16 UTC
The sidebar should not be dockable above or below the edit window.  This has worked in the past and seems to be broken.
Comment 5 Andre 2013-05-16 09:55:27 UTC
The missing closer was caused by the sidebar remembering its split window (the container that holds docked windows.)  When undocked and then docked at another place the split window pointer was not updated but still referenced the old one.  The following test, whether the split window allowed the sidebar to change its size (only then the closer is active), failed because the wrong split window was used.

Fixed by updating the split window pointer.

I also added the missing code for preventing the sidebar being docked above or below the edit view.
Comment 6 SVN Robot 2013-05-16 10:04:42 UTC
"af" committed SVN revision 1483283 into trunk:
122320: Show closer after docking sidebar.  Prevent sidebar from being docked...