Issue 122306 - Calc fails transforming galician month's names in format DMY
Calc fails transforming galician month's names in format DMY
Status: RESOLVED FIXED
Product: Internationalization
Classification: Code
Component: localedata
3.4.1
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
: data_loss, numbering
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 23:18 UTC by Antón Méixome
Modified: 2013-05-14 00:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 3.4.0
Developer Difficulty: ---


Attachments
Writer document with Date field with format NN DD/MMM YY (8.52 KB, application/vnd.oasis.opendocument.text)
2013-05-14 00:19 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Antón Méixome 2013-05-13 23:18:41 UTC
Problem description: 

Calc not recognize month's names in galician when importing a list of ítems. Only recognize the names been the same for english. In import dialog you can set the language for import but Calc is not interpreting correctly.

Steps to reproduce it:

1. Look at this serie

1 Xan, 2012
2 Feb, 2012
3 Mar, 2012
4 Abr, 2012
5 Mai, 2012
6 Xuñ, 2012
7 Xul, 2012

You have the items in a txt document, without formating. Then, you copy the serie and paste it inside a cell of Calc. Calc open import dialog. Set the galician language. Set the type of data fron «Standard» to DMA (interface in english=DMY). 


Current behavior:

1 Xan, 2012
02/02/12
03/03/12
4 Abr, 2012
5 Mai, 2012
6 Xuñ, 2012
7 Xul, 2012

My actual default format for data is DD/MM/YY

Expected behavior:

01/01/12
02/02/12
03/03/12
04/04/12
05/05/12
06/06/12
07/07/12

I was testing if this is reproducible in spanish or portuguese and not. It's only for galician names and in various versions. I don't know when this behavior appeared.

Otherwise, I find a related question and I think this would be improved.
If you have a list with errors in names (e.g. if you merge names in different languages or having misspelled words or the abreviations are inexact) Calc accept if matching the english forms.

e.g.
Serie en portuguese with errors

1 Jan, 2012
2 Feb, 2012
3 Mar, 2012
4 Abr, 2012
5 May, 2012
6 Jun, 2012
7 Jul, 2012

seen in Calc

01/01/12
02/02/12
03/03/12
04/04/12
05/05/12
06/06/12
07/07/12

Calc transforms it correctly, even when there are some errors (Feb→Fev; May→Mai)
but, ... these "errors" matchs with english forms...

Reverse ? No, of course. Look

Serie for english with "errors" in portuguese

1 Jan, 2012
2 Feb, 2012
3 Mar, 2012
4 Abr, 2012
5 Mai, 2012
6 Jun, 2012
7 Jul, 2012

Results

01/01/12
02/02/12
03/03/12
4 Abr, 2012
5 Mai, 2012
06/06/12
07/07/12

This is the probe. Calc refuse admits in english "Abr" or "Mai" but
accepts "Feb" or "May" in portuguese.

What's the improve? 
If you set the import language to "x" for a dataset Calc must refuse perform a inaccurate filter with other language.

Of course, the bug is prior!

              
Operating System: All
Version: unspecified
Comment 1 Ariel Constenla-Haile 2013-05-13 23:47:07 UTC
(In reply to comment #0)
> I was testing if this is reproducible in spanish or portuguese and not. It's
> only for galician names and in various versions. I don't know when this
> behavior appeared.

There is a bug in the locale data, abbreviate month names are using a dot:

http://svn.apache.org/viewvc/incubator/ooo/trunk/main/i18npool/source/localedata/data/gl_ES.xml?revision=1306262&view=markup#l241

After removing the dots, copy

1 Xan, 2012
2 Feb, 2012
3 Mar, 2012
4 Abr, 2012
5 Mai, 2012
6 Xuñ, 2012
7 Xul, 2012

paste into Calc as plain text. Set locale to Galician and date format as DMY, you get

01/01/12
02/02/12
03/03/12
04/04/12
05/05/12
06/06/12
07/07/12
Comment 2 Ariel Constenla-Haile 2013-05-13 23:54:01 UTC
(In reply to comment #0)
> I don't know when this behavior appeared.

It's been there since the beginning:
http://hg.services.openoffice.org/OOO340/log/c904c1944462/i18npool/source/localedata/data/gl_ES.xml
Comment 3 Ariel Constenla-Haile 2013-05-13 23:57:18 UTC
@Antón: can you try with abbreviated day names? They have the same bug (a dot at the end), but I cannot confirm this without installing a language pack (and I'm lazy to do this right now).
Comment 4 Ariel Constenla-Haile 2013-05-14 00:13:50 UTC
(In reply to comment #3)
> @Antón: can you try with abbreviated day names? They have the same bug (a
> dot at the end), but I cannot confirm this without installing a language
> pack (and I'm lazy to do this right now).

I can reproduce it in Writer, no need to install a langpack:

Insert a data field, an apply the following format:

Spanish (Argentina)
NN DD/MMM AA
lun 13/may 13

Emglish (USA)
NN DD/MMM YY
Mon 13/May 13

Galician
NN DD/MMM YY
lun. 13/mai 13

As seen, in Galician there is a dot in lun. but would belong to the format 
"NN. DD/MMM YY"
Comment 5 Ariel Constenla-Haile 2013-05-14 00:18:03 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > @Antón: can you try with abbreviated day names? They have the same bug (a
> > dot at the end), but I cannot confirm this without installing a language
> > pack (and I'm lazy to do this right now).
> 
> I can reproduce it in Writer, no need to install a langpack:
> 
> Insert a data field, an apply the following format:

I meant a date field, from Insert - Fields - Date
Comment 6 Ariel Constenla-Haile 2013-05-14 00:19:32 UTC
Created attachment 80679 [details]
Writer document with Date field with format NN DD/MMM YY

In 3.4.1:

Format: NN DD/MMM YY
Locale: Galician
lun. 13/mai. 13

After the fix:

Format: NN DD/MMM YY
Locale: Galician
lun 13/mai 13
Comment 7 SVN Robot 2013-05-14 00:23:04 UTC
"arielch" committed SVN revision 1482157 into trunk:
i122306 - Remove dot from abbreviate day and month names in Galician
Comment 8 Ariel Constenla-Haile 2013-05-14 00:23:49 UTC
Fixed on trunk