Issue 122291 - [Sidebar] layout panel empty in normal view/Slide Sort View /Slide Master View/Notes View
[Sidebar] layout panel empty in normal view/Slide Sort View /Slide Master Vie...
Status: VERIFIED FIXED
Product: Impress
Classification: Application
Component: ui
4.0.0-dev
PC Linux64
: P3 blocker (vote)
: 4.0.0
Assigned To: Andre
edoardopanfili
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-11 19:59 UTC by Edwin Sharp
Modified: 2013-07-11 14:41 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Edwin Sharp 2013-05-11 19:59:40 UTC
Test Case ID AOOTest-1139 :: Version : 1 

AOO400m1(Build:9700)
2013-05-03 07:08:08 (Fri, 03 May 2013) - Linux x86_64
Comment 1 liuping 2013-05-20 10:03:39 UTC
AOOTest-1139 Steps
1.New a Impress.
2.Insert several slides.
3. Select some slides via Slide Pane, then click on one layout in sidebar.
 
Expected Results 
Specific page layout is applied on selected slides, related layout in sidebar is selected.

Actual Results:
Failed - Step #3 ,there are no layouts in the sidebar.
Comment 2 liuping 2013-05-20 10:07:22 UTC
OOTest-1149 
Steps

1.New a Impress, then switch to Slide Sort View.

2.Insert several slides.

3.Click on one slide (blank area), then click on one layout in sidebar.


Expected Results 
Specific page layout is applied on selected slides, related layout in sidebar is selected.

Actual Results:
Failed - Step #3 ,there are no layouts in the sidebar.
Comment 3 liuping 2013-05-20 10:11:27 UTC
AOOTest-1148

Steps:
1.New a Impress, then switch to Slide Master View.
2.Insert several slides.
3.Change page layout for a slide

Expected Results 
Page layout is changed.

Actual Results:
Failed - Step #3 ,there are no layouts in the sidebar.
Comment 4 liuping 2013-05-20 10:20:13 UTC
AOOTest-1146

Steps:
1.New a Impress.
2.Check available page layouts under Notes View.
3.Check available page layouts under Notes View

Expected Results 
The following layouts should be in the list: 'Notes'
 

Actual Results:
Failed - [Sidebar] layout panel empty on linux 64-bit
Comment 5 Regina Henschel 2013-05-20 13:55:59 UTC
It works for me with r1483903 on Windows7. There are only some little deficiencies:
-The initial desk is empty in handout view, you need to click on a preview object.
-The marker in the layout panel does not follow the marked slides, when you traverse the slides in the slide sorter using the arrow left key, but works with arrow right key.

@liupingtan: Which revision do you use?
Comment 6 Andre 2013-05-21 09:25:11 UTC
In can only reproduce the first point of Regina's last comment.
Fixed that and a paint error of the layout panel selection.  Maybe that is connected with Regina's second point?
Comment 7 SVN Robot 2013-05-21 09:25:58 UTC
"af" committed SVN revision 1484711 into trunk:
i122291: Showing the right set of layouts for handout mode.  Fixed painting s...
Comment 8 Regina Henschel 2013-05-21 13:38:26 UTC
Repaint error and the empty panel (=first error) are fixed, but traversing (=second error) is still false. I have written bug 122354 for it.
Comment 9 edoardopanfili 2013-07-06 13:26:46 UTC
test reported as AOOTest-1139 Steps from liupingtan 
works in OS X 10.8
AOO400m2(Build:9701)  -  Rev. 1496831
2013-06-25 15:52:47 (Tue, 25 Jun 2013)
and in Windows 8
AOO400m2(Build:9701)  -  Rev. 1489073
2013-06-03 13:48:37 (Mo, 03 Jun 2013)

the two points from Regina Henschel
-the initial desk now is not empty in both OS X an Windows.
-i can0t reproduce the second point can youdetail a test case?
Comment 10 Regina Henschel 2013-07-06 13:36:50 UTC
My second point has got an own issue, see bug 122354. Please verify that one.