Issue 122275 - [Sidebar] Slide master layout not changing
[Sidebar] Slide master layout not changing
Status: RESOLVED FIXED
Product: Impress
Classification: Application
Component: formatting
4.0.0-dev
PC Windows 7
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-10 08:30 UTC by Edwin Sharp
Modified: 2013-07-11 14:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Edwin Sharp 2013-05-10 08:30:18 UTC
Test Case ID AOOTest-1147 :: Version : 1 

View - Master - Slide Master
Click on slide
Click on layout in sidebar
Layout is not applied to current slide

Rev. 1479897
Comment 1 Armin Le Grand 2013-05-13 12:27:33 UTC
ALG: When doing
- Start Impress
- Choose view/master/Slide Master
I have no Layouts panel in Properties sidebar.
What I have is a MasterPages SIdebar (also visible when not on MasterPage) to add another MasterPage.
-> cannot reproduce.
Comment 2 Edwin Sharp 2013-05-13 12:56:14 UTC
From test action description:

"Switch to Slide Master View. Click on one slide (blank area), then click on one layout in sidebar. -> Specific page layout is applied on current slide, related layout in sidebar is selected."
Comment 3 Andre 2013-05-13 13:01:09 UTC
The described problem has the same root cause as bug 122093: the layout panel can not handle master pages.  Therefore it should not be displayed when in master page mode.  My fix for bug 122093 seems not to cover all cases.  When clicking on the slide sorter and then on the slide in the edit view is not handled properly.  The context is DrawPage but should be MasterPage.
Comment 4 SVN Robot 2013-05-13 13:34:47 UTC
"af" committed SVN 0 into trunk:
122275: Don't show the layout panel for master pages.
Comment 5 Andre 2013-05-13 13:36:50 UTC
Fixed by changing the context that is notified by DrawViewShell::Activate() depending on the edit mode.