Issue 122271 - [sidebar] Content panel title - no associated detail for annotation when gaining focus (W, C, I, D)[ia2]
[sidebar] Content panel title - no associated detail for annotation when gain...
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
: accessibility
Depends on:
Blocks: [sidebar] 122380
  Show dependency treegraph
 
Reported: 2013-05-09 23:16 UTC by V Stuart Foote
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description V Stuart Foote 2013-05-09 23:16:32 UTC
AOO400m1(Build:9700) build of 2013-05-09_04:09:59 - Rev. 1480523

When navigating Sidebar panels with cursors <DOWN>,<UP>,<LEFT> or <RIGHT> as focus shifts to each Content panel title, there is no associated detail for annotation. Assistive technology sounds simply "Panel" for each no way to distinguish where in sidebar positioned.

Issue migrated from bug 122247
Comment 1 Andre 2013-05-15 07:58:31 UTC
This should be easy to fix by explicitly setting accessible name and description of panels to something like
    Panel: <title-of-panel>

For the text property panel this would be
    Panel: Text
Comment 2 Andre 2013-05-15 07:58:31 UTC
This should be easy to fix by explicitly setting accessible name and description of panels to something like
    Panel: <title-of-panel>

For the text property panel this would be
    Panel: Text
Comment 3 SVN Robot 2013-05-16 08:49:37 UTC
"af" committed SVN revision 1483251 into trunk:
122271: Provide accessible for panels that includes the panel title.
Comment 4 Andre 2013-05-16 08:50:41 UTC
Fixed as outlined above.  I currently do not have accessibility support installed on my machine, so I could not test this.
Comment 5 V Stuart Foote 2013-05-21 16:56:38 UTC
Reopening.

On ia2 build
AOO400m1(Build:9700)  -  Rev. 1484333
2013-05-20_04:12:39 - Rev. 1484373

and current core build

AOO400m1(Build:9700)  -  Rev. 1484333
2013-05-20_04:12:39 - Rev. 1484373

Content Panel Title bars do not seem to be receiving accessibility focus events - result that no Title or accName is available when object focus with cursor movements occurs between each panel on the deck, and also for the deck title bar. Once a content panel is opened accessibility an accessibility focus event is made and element on the panel are titled.

So just the content panel title bars and the deck title bar lack accessibility focus events.
Comment 6 V Stuart Foote 2013-05-21 17:02:16 UTC
Oops, make those rev versions

On ia2 build
AOO400m1(Build:9700)  -  Rev. 1484083
Rev.1484083

and current core build
AOO400m1(Build:9700)  -  Rev. 1484333
2013-05-20_04:12:39 - Rev. 1484373
Comment 7 Andre 2013-05-23 14:52:28 UTC
After my changes for bug 122247 the missing detail information and accessibility event probably has to be extended to deck titles because these can now be focused as well.
Comment 8 V Stuart Foote 2013-05-23 16:08:21 UTC
@Andre,

I think the deck and panel titles already could be focused because you COULD reach them with cursor movements--they just were empty.  Not a problem for GUI direct click focus, but always an issue for use with AT and keyboard navigation.

None the less -- Thank you, for knocking these annoyances out!
Comment 9 Andre 2013-05-24 07:30:13 UTC
Keyboard focus and accessibility (focus) events are two separate things.  I have to find out why they are not kept in sync.

By the way, thank you very much for your testing work.  The descriptions and their level of detail are invaluable to me for fixing these bugs.
Comment 10 Andre 2013-05-30 15:04:41 UTC
I have found the root cause for the missing focus events.  At least on Windows.  

In our supporting code of the Java access bridge (under main/accessibility/bridge/) there is an implementation of the javax.accessibility.AccessibleComponent interface.  The return value of its isFocusTraversable() method controls whether a control can accept the focus or not.  The implementation of this method returns true when the state set has flag FOCUSABLE set.  This is not the case for the title bars in the sidebar.  Therefore they never get the accessibility focus, even though they have the regular input focus.

I have experimentally set the FOCUSABLE flag for all objects (that use the default implementation in toolkit/awt/) and the sidebar TitleBar objects generate accessibility events.

Remains to find out how to set this flag in a proper way only for the TitleBar objects.
Comment 11 SVN Robot 2013-05-31 09:07:07 UTC
"af" committed SVN revision 1488132 into trunk:
122271: Setting FOCUSABLE flag at accessibility object sidebar title bars
Comment 12 Andre 2013-05-31 09:19:58 UTC
The sidebar title bar objects now create a sub class of VCLXAccessibleComponent that explicitly add the FOCUSABLE flag to their set of accessibility states.  This causes title bars of decks and panels to become visible to JavaFerret on Windows and accercizer on Linux (yes, I got the later one to work, after clicking away some warning boxes regarding errors with some system processes).

I will set this bug now to fixed but I could still do some minor changes to the accessible names and descriptions.

@Stuart:  At the moment the accessible names and descriptions are identical.  For decks they are the title of the deck.  For panels then title is prefixed with "Panel :".  The word "panel" may be added also by AT devices and then be read twice.  Therefore it might be better to drop the "Panel :" prefix.
Do you have any preferences.
Comment 13 V Stuart Foote 2013-05-31 10:46:10 UTC
(In reply to Andre from comment #12)
> 
> @Stuart:  At the moment the accessible names and descriptions are identical.
> For decks they are the title of the deck.  For panels then title is prefixed
> with "Panel :".  The word "panel" may be added also by AT devices and then
> be read twice.  Therefore it might be better to drop the "Panel :" prefix.
> Do you have any preferences.

I'd say drop the "Panel :" prefix from the content panel title and allow the AT to report based on the assigned role--and eliminate source of the redundancy. 

Just be consistent choosing accessibility roles for the  sidebar components. 

And, poke Steve for imput as well, he may have specific UAA accessibility roles in mind to use for the IA2 bridge.
Comment 14 SVN Robot 2013-05-31 11:29:02 UTC
"af" committed SVN revision 1488172 into trunk:
122271: Added missing files.
Comment 15 SVN Robot 2013-05-31 12:35:18 UTC
"af" committed SVN revision 1488191 into trunk:
122271: Added missing include.