Issue 122260 - [sidebar]: 'Show Shapes' Icon truncated in Navigator Panel by useless grey area
[sidebar]: 'Show Shapes' Icon truncated in Navigator Panel by useless grey area
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
PC Windows 7
: P3 trivial (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-09 06:26 UTC by Rainer Bielefeld
Modified: 2013-07-01 11:29 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Screenshot (71.71 KB, application/x-download)
2013-05-09 06:26 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Rainer Bielefeld 2013-05-09 06:26:31 UTC
Created attachment 80655 [details]
Screenshot

Steps how to reproduce with server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev.1476029]" on WIN7 Home Premium (64bit)", own separate user profile:

0. Launch AOO
1. From AOO Start Center open new Drawing
   > Sidebar shown docked at the right
2. In sidebar click Navigator' icon
   > Navigator contents appears
  Bug: only left half of 'Show Shapes' shown

Additional info:
Problem 
a) disappears with undocked sidebar
b) is related to menu 'Tools -> Options -> OO -> View - UI -Scaling'
   With scaling 80% in additional step 0.1 the problem will disappear
   With staling 130% the icon will disappear completely
d) May be this one is no longer relevant with fix for 
   "Bug 122178 - [sidebar] Unable to re-size the sidebar"? I will check that 
    soon!
e) also Navigator Siedbars for other applications show similar truncations, I
   will wait for my test results "d" before I submit Bug reports for those 
   problems
Comment 1 Rainer Bielefeld 2013-05-09 07:12:38 UTC
Still reproducible with server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev. 1479897 (2013-05-09)]" on WIN7 Home Premium (64bit)", own separate user profile.
At the right end there is a grey area (for unknown reason) behind what the icon will disappear when you decrease width of sidebar.

CONFIRMED due to result in different build
Comment 2 Oliver-Rainer Wittmann 2013-05-13 10:19:29 UTC
I can not reproduce the described defect in recent developer snapshot build (AOO400m1(Build:9700)  -  Rev. 1479897) in my environment (Win7 professional 64bit, English UI, German locale)
Comment 3 Rainer Bielefeld 2013-05-13 11:03:32 UTC
@Oliver-Rainer Wittmann
I'll try latest build until evening
Comment 4 Oliver-Rainer Wittmann 2013-05-13 11:38:47 UTC
(In reply to comment #3)
> @Oliver-Rainer Wittmann
> I'll try latest build until evening

Thx.

I can also not reproduce the defect in former developer snapshot (AOO400m1(Build:9700)  -  Rev. 1478648) on my Windows 7 Pro (64bit)
Comment 5 Armin Le Grand 2013-05-13 12:16:25 UTC
ALG: Can also not reproduce on r1481724
Comment 6 Rainer Bielefeld 2013-05-14 04:18:29 UTC
(In reply to comment #3)
Sorry, all my attempts to get a current WIN build from <https://cwiki.apache.org/confluence/display/OOOUSERS/Development+Snapshot+Builds> failed, all download results were much too small files.
Comment 7 Oliver-Rainer Wittmann 2013-05-14 09:28:29 UTC
(In reply to comment #6)
> (In reply to comment #3)
> Sorry, all my attempts to get a current WIN build from
> <https://cwiki.apache.org/confluence/display/OOOUSERS/
> Development+Snapshot+Builds> failed, all download results were much too
> small files.

Hm.. I have downloaded yesterday successfully Linux 64bit DEB
Comment 8 Oliver-Rainer Wittmann 2013-05-14 09:30:21 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #3)
> > Sorry, all my attempts to get a current WIN build from
> > <https://cwiki.apache.org/confluence/display/OOOUSERS/
> > Development+Snapshot+Builds> failed, all download results were much too
> > small files.
> 
> Hm.. I have downloaded yesterday successfully Linux 64bit DEB

I have just downloaded the Windows installation set
Comment 9 Rainer Bielefeld 2013-05-15 13:09:35 UTC
Still reproducible with server installation of  "AOO 4.0.0-Dev – English UI / German locale [AOO400m1(Build:9700) - Rev. Rev. 1482523 Rev.1482259 (2013-05-15)]" on WIN7 Home Premium (64bit)", own separate user profile.

All the same when docked at the left.
Comment 10 Rainer Bielefeld 2013-05-15 13:51:36 UTC
My PC (unrelated): 64 bit AMD Phenom II X4 955 Processor 3.2 GHz, 4GB RAM, 
Graphic Card: NVIDIA GeForce GT 430, Monitor HANNS-G HL225DBB 1920 x 1080 

I tried same " Rev. 1482523 Rev.1482259 " on my WIn 7 64bit laptop: no problem
strange!

I did some more research and found that the problem is related to WIN settings (all: translated from German UI)

a) 'Rrightclick on desktop -> Customize -> See also - Display'
  > Dialog "Ease readability" appears
b) Select radio button 125% (old: 100%)
c) logout WIN user -> LOGIN again -> proceed as per original report
   > Now you should be able to reproduce my problem. At least on my Laptop
     the problem became reproducible after these changes.
Comment 11 Oliver-Rainer Wittmann 2013-05-17 12:50:30 UTC
I have reproduced the described defect on a Windows 7 Home Premium by changing the mentioned Windows setting.

It looks like a general Navigator layout problem which becomes more obvious with the sidebar feature, because the Navigator in the sidebar could be made smaller than the plane one:
- Calc Navigator - also the plane Navigator shows 'bad' layout - the control for 'Row' is cut.
- Draw/Impress Navigator - with the "100% Windows settings" the toolbar on top is as wide as the list of slides; with "125% Windows settings" it is smaller, but the plane Navigator could not be made small enough to show the described defect.

I did not observe a 'bad' layout in the Writer Navigator.

Can somebody have a look at other platforms?
Comment 12 SVN Robot 2013-05-21 13:31:56 UTC
"orw" committed SVN revision 1484805 into trunk:
122260: Calc Navigator - assure that tool box is at least as wide as the tree...
Comment 13 Oliver-Rainer Wittmann 2013-05-21 13:47:27 UTC
fixed Draw/Impress Navigator layout on trunk for AOO 4.0

Note:
fix for Calc Navigator is in progress - see bug 122261