Issue 122247 - [sidebar] keyboard traps when navigating with cursor keys, F6 and TAB
[sidebar] keyboard traps when navigating with cursor keys, F6 and TAB
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
: accessibility
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-07 14:45 UTC by V Stuart Foote
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description V Stuart Foote 2013-05-07 14:45:09 UTC
on Windows 7, 64bit with JRE 1.6.45 and JAB 2.0.2 configured.

Apache OpenOffice 4.0 build AOO400m1(Build:9700) - Rev. 1478648

First time in Sidebar (sorry to be so late, had spent more time with the IA2 branch builds).

Anyhow, seem to be a number of keyboard traps in all of the Properties pannels, able to <TAB> and <shift><TAB>, as well as <LEFT><UP><RIGHT><DOWN> cursor, but once in a selection list, unable to exit. <ESC>, <CTL>Z don't return ability to navigate to next Property panel.  Only exit is an <F6>, which rotates to the next Frame and out of the sidebar.  Occurs with Sidebar docked or un-docked.

Also, when entering the Sidebar with <F6> or <shift><F6>, there is no annotation assigned to the focus event when entering the Properties panel, nor when cursoring from property panel to property panel.  That may be an issue for the IA2 integration, but as it is now it is not navigable with Java Access Bridge. 

Will check against ATK to see if it is an issue there.
Comment 1 V Stuart Foote 2013-05-07 14:56:19 UTC
setting as unconfirmed since that's a bit nicer for my own bug report, but it is a valid accessibility issue with Sidebar.
Comment 2 V Stuart Foote 2013-05-07 22:03:56 UTC
Adjusting to the correct nomenclature per http://wiki.openoffice.org/wiki/File:SidebarNames.png

>Also, when entering the Sidebar with <F6> or <shift><F6>, there is no annotation >assigned to the focus event when entering the Properties panel, nor when >cursoring from property panel to property panel.

...when entering the Sidebar with <F6>... there is no annotation assigned to the focus event for the "Title bar", or when cursoring through "Content Panel Title"'s of the content panels present in the "Deck".

Once inside the "Content panel" there is audible annotation.
Comment 3 Andre 2013-05-08 11:15:30 UTC
Confirmed.

@ V Stuart Foote: The cursor traveling should be better now.  Can you check again with a new snapshot build that are currently being built?
Comment 4 V Stuart Foote 2013-05-09 00:02:02 UTC
Andre,

=-=-=
Navigation - Keyboard traps

With yesterdays Windows snapshot build of  AOO400m1(Build:9700) - Rev. 1479897, the keyboard navigation is much better! But still have a few movement issues.

F6 & <shift>F6 cycle between frames cleanly

TAB & <Shift>TAB move between content pannel property features 

Cursors <LEFT> & <RIGHT> move between selections
Cursor <UP> & <DOWN> are active with dropdown lists

<ESC> exits current content pannel and returns focus to the "Content panel title" Any of the cursor <UP> & <LEFT> move to prior, <DOWN> & <RIGHT> move to next  "Content Panel Title", out of the "Deck" and into the "Tab bar" to each configuration button in turn.

But a little glitch with the Writer -> Sidebar -> Paragraph Line Spacing - drop down and cursor <UP> & <DOWN> where it opens and closes the dropdown list with each cursor press for the preset spacings. Actually crashed AOO and recovered session when cursoring too fast through the line spacing drop list.

Also a little glitch with the objects on the Tab Bar for the radio button tab buttons. The Properties tab seems to behave when exiting each content panel with an <ESC>, and then cursoring around to the Tab Bar. However, even though the Properties content panel is active--the radio button role is NOT CHECKED, rather the next radio button for Styles and Formatting is checked--so I believe that the startup default is wrong. And if using a mouse, select does set the radio button checked and once set, with either mouse or cursor key the radio button checked role does cycle through matching against the active Tab bar.

Unlike the Properties tab, for the other content panels (in Writer at least) while in the content panel you can tab and cursor between content panel properties, but you get stuck and are unable to exit from the: 
   Styles and Formatting tab panel 
   Gallery tab panel

That is <ESC> does not exit the tray--and only an F6 cycles to the next frame and shift-F6 back to the Title Bar.

Similar for: 
   Navigator tab panel...
except that <ESC> always returns to the "Toggle button, switches between master view and normal view if the Master view is open"--only an F6 cycles to next frame. 


=-=-=
Annotation of Focus events

No usable annotation of the Sidebar "Title Bar". On entry it lands on the "X" close button of the Title Bar and announces "Split pane" "Properties Panel" "Toolbar Button" on landing.  

But also, cursor navigation down into to each "Content panel title" is not annotated when focus is gained, e.g. titles are silent to Assistive Technology.  

Continuing and entering a TAB moves focus to the "Toolbar" button of the Content panel title but lists nothing more about the object.  A subsequent TAB moves into the "Content Panel"  and finally announces the panel title and the first property object. An <ESC> to exit content panel returns focus back to its panel title, but again there is no annotation associated with the title gaining focus.

When landing in the tab bar by using cursor movements to cycle from the deck to the tab bar holding the Properties panel. Each content panel tab button is identified as a Radio Button role with annotation of its Property Panel title. 

When the Component panel for the Tab bar is activated, and focus jumped into component panel seemed to have pretty complete role annotation and descriptions of each element inside the Component panels.

=-=-=
This 1479897 snapshot build did not yet have the work for bug 122251 and the Calc active cell drift. I will keep an eye on the next Dev build snapshots, maybe even the Linux-64 build to test this again.
Comment 5 V Stuart Foote 2013-05-09 22:47:20 UTC
(In reply to comment #4)

> But a little glitch with the Writer -> Sidebar -> Paragraph Line Spacing -
> drop down and cursor <UP> & <DOWN> where it opens and closes the dropdown
> list with each cursor press for the preset spacings. Actually crashed AOO
> and recovered session when cursoring too fast through the line spacing drop
> list.
> 
Have moved this to an issue of its own, bug 122270
Comment 6 V Stuart Foote 2013-05-09 22:48:01 UTC
(In reply to comment #4)

> Also a little glitch with the objects on the Tab Bar for the radio button
> tab buttons. The Properties tab seems to behave when exiting each content
> panel with an <ESC>, and then cursoring around to the Tab Bar. However, even
> though the Properties content panel is active--the radio button role is NOT
> CHECKED, rather the next radio button for Styles and Formatting is
> checked

This is correctly configured with the AOO400m1(Build:9700) 2013-05-09_04:09:59 build - Rev. 1480523, Sidebar opens with Properties panel active and its radio button selected.
Comment 7 V Stuart Foote 2013-05-09 23:18:52 UTC
(In reply to comment #4)

> Annotation of Focus events...
> 
> But also, cursor navigation down into to each "Content panel title" is not
> annotated when focus is gained, e.g. titles are silent to Assistive
> Technology.  
> 

Moving this to an issue of its own, bug 122271
Comment 8 V Stuart Foote 2013-05-09 23:44:12 UTC
(In reply to comment #6)
> (In reply to comment #4)
> 
> > Also a little glitch with the objects on the Tab Bar for the radio button
> > tab buttons. The Properties tab seems to behave when exiting each content
> > panel with an <ESC>, and then cursoring around to the Tab Bar. However, even
> > though the Properties content panel is active--the radio button role is NOT
> > CHECKED, rather the next radio button for Styles and Formatting is
> > checked
> 
> This is correctly configured with the AOO400m1(Build:9700)
> 2013-05-09_04:09:59 build - Rev. 1480523, Sidebar opens with Properties
> panel active and its radio button selected.

Opened a new issue for Tab bar radio button selection status not following selections made with Configuration menu button. Bug 122272
Comment 9 V Stuart Foote 2013-05-09 23:50:22 UTC
(In reply to comment #4)
> Navigation - Keyboard traps
> 
> Unlike the Properties tab, for the other content panels (in Writer at least)
> while in the content panel you can tab and cursor between content panel
> properties, but you get stuck and are unable to exit from the: 
>    Styles and Formatting tab panel 
>    Gallery tab panel
> 
> That is <ESC> does not exit the tray--and only an F6 cycles to the next
> frame and shift-F6 back to the Title Bar.
> 
> Similar for: 
>    Navigator tab panel...
> except that <ESC> always returns to the "Toggle button, switches between
> master view and normal view if the Master view is open"--only an F6 cycles
> to next frame. 
> 
For AOO400m1(Build:9700) build of 2013-05-09_04:09:59 - Rev. 1480523

At this point all other issues except keyboard traps have been removed from this bug.

Adjusting title of summary -- [sidebar] keyboard traps when navigating with cursor keys, F6 and TAB
Comment 10 V Stuart Foote 2013-05-11 20:20:50 UTC
restating the remaining keyboard traps from comment 4, but may be others

Unlike the Properties tab, for the other content panels (in Writer at least) while in the content panel you can tab and cursor between content panel properties, but you get stuck and are unable to exit from the: 
   Styles and Formatting tab panel 
   Gallery tab panel

That is <ESC> does not exit the tray--and only an F6 cycles to the next frame and shift-F6 back to the Title Bar.

Similar for: 
   Navigator tab panel...
except that <ESC> always returns to the "Toggle button, switches between master view and normal view if the Master view is open"--only an F6 cycles to next frame.
Comment 11 Andre 2013-05-22 12:49:28 UTC
This works as designed but not as intended :-)
The ESC key is received and processed by the sidebar FocusManager.  It then puts the focus back to the panel.  The problem is that the panel does not show its title bar.  That has been optimized away because in case of the gallery, navigator and styles&formatting there are no other panels.  Additionally panel and deck title bar would show the same string.  As a result the focus is moved back into the panel content, right where it was before ESC was pressed.

My proposal for a fix is to make the deck title bar able to receive the focus.  Up to now I did not do that on purpose because the deck title does not offer any functionality, it just displays a string.  Making it focusable would have two advantages:

- When the panel title bar does not exist and ESC is pressed then the focus can be moved to the deck title bar and not to the panel content.

- When the focus is moved via F6 to the sidebar then focus the deck title bar instead of the closer.  This should give a better indication of where the focus is.
Comment 12 SVN Robot 2013-05-23 14:30:18 UTC
"af" committed SVN revision 1485730 into trunk:
122247: Improved focus traveling in sidebar.
Comment 13 Andre 2013-05-23 14:35:13 UTC
Fixed as outlined above. 

UI Changes:

1. The deck title bar is now focusable and is focused when focus is set to sidebar via F6.

2. Tab in deck title moves focus between deck title and deck closer.
2a. When the only panel does not show its title bar then TAB moves focus from deck closer to panel content, just like in panel title bars.

3. Tab will move focus eventually from panel content back to panel title (or deck title when panel title is not shown).


I hope this is new behavior is more intuitive to use.
Comment 14 V Stuart Foote 2013-05-23 15:57:50 UTC
@Andre,

That sounds correct. OK to assume that FocusManager handling of the <ESC> will exit the active panel back to its respective title, or to the deck title with the single panel decks.

NTL will test next available build with rev 1485730 included.

Stuart
Comment 15 V Stuart Foote 2013-05-25 08:46:05 UTC
r1485730 was on track, the <ESC>, <TAB>, and Cursor behavior seems more reliable for move into and out of content panels and titles in the deck. Resolving the keyboard traps--confirm resolved fixed. 

Unfortunately changes resulted in regression of handling cursor movement, focus and action on some toolbars. See bug 122379