Issue 122230 - [sidebar] problems with F6 (accessibility) in tab bar
[sidebar] problems with F6 (accessibility) in tab bar
Status: RESOLVED FIXED
Product: Draw
Classification: Application
Component: ui
4.0.0-dev
PC Windows 7
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
: accessibility
Depends on:
Blocks: winA11y [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-04 21:21 UTC by Regina Henschel
Modified: 2013-07-11 14:41 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2013-05-04 21:21:48 UTC
Apache OpenOffice should be usable without mouse, but I see some problems in the new sidebar.

Open a Draw document.
Undock the sidebar.
Cycle through toolbars and subwindows using the F6 key.
Notice, that you can reach the 'deck' but not the 'tab bar'.

Dock the sidebar.
Again cycle through toolbars and subwindows using the F6 key.
Now you can reach the configuration menu button.
Try to go to the tabs. Notice, that up and left arrow work, but right and down arrow not.

Cycle with left or up arrow to the 'configuration menu button'. Open it by pressing Enter key. Use up or left arrow to go to Navigator or Gallery item and activate is by pressing Enter key. Try to set focus to the now open Navigator or Gallery. Try to set focus to the document, which should be Ctrl-F6. Nothing works. There is no way to close the configuration menu.
Comment 1 SVN Robot 2013-05-06 13:12:21 UTC
"af" committed SVN revision 1479558 into trunk:
122230: Fixed focus traveling in the sidebar.
Comment 2 Andre 2013-05-06 13:12:51 UTC
Confirmed.  The F6 problem is caused by my attempt to replicatin the Symphony behavior of F6 switching between deck and tab bar.
Comment 3 Andre 2013-05-06 13:17:30 UTC
Fixed by changing the focus traveling behavior.  From the FocusManager header:

    There is one ring of windows that accept the input focus which are
    cycled through with the arrow keys:
    - the closer in the deck title (present only when docked)
    - the panel title bars
    - the tab bar items

    When the focus is in a panel title then focus travels over
    - the panel title
    - the panel closer
    - the panel content

    Once the focus is in the panel content then focus cycles through
    all controls inside the panel but not back to the title bar of
    the panel.  Escape places the focus back in the panel title.
Comment 4 Ariel Constenla-Haile 2013-05-06 14:12:11 UTC
(In reply to comment #1)
> "af" committed SVN revision 1479558 into trunk:
> 122230: Fixed focus traveling in the sidebar.

There is a crash after this commit:

- New writer document
- The properties panel is selected by default
- with the mouse, select the navigator
- then select the gallery
- Crash
Comment 5 SVN Robot 2013-05-07 11:44:16 UTC
"af" committed SVN revision 1479864 into trunk:
122230: Fixes for sidebar focus traveling.