Issue 122219 - [Sidebar] Properties items unsteady
[Sidebar] Properties items unsteady
Status: RESOLVED FIXED
Product: Calc
Classification: Application
Component: ui
4.0.0-dev
PC Windows 7
: P3 major (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-03 11:08 UTC by Edwin Sharp
Modified: 2013-07-11 13:57 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Edwin Sharp 2013-05-03 11:08:01 UTC
Cell Appearance and Number Format are blinking when inserting data into cells.

During typing: Text and Alignment are visible
After Enter before typing into next cell: Text, Alignment, Cell Appearance and Number Format are visible

Rev. 1476029
Comment 1 Andre 2013-05-08 12:10:35 UTC
I can not reproduce this bug.

There are two contexts with different sets of visible panels involved here:

- When a cell is selected but not currently being edited then four panels are visible:
    Text, Alignment, Cell Appearance, Number Format (not expanded by default)

- When text in a cell is being edited then only two panels are visible:
    Text and Alignment

Therefore the number of visible panels changes every time text editing starts or ends.


@Edwin Sharp: Can you still reproduce an error with a recent snapshot build?  Platform is Windows7?
Comment 2 Edwin Sharp 2013-05-08 13:37:13 UTC
You say you can not reproduce but then describe the bug...
Will try recent snapshot later, Windows 7 it is.

There can be no two contexts and when cells are populated with data the contexts are jumping back and forth.
It is annoying and distracting.
GUI should be static during data input.
Comment 3 Edwin Sharp 2013-05-08 16:46:51 UTC
(In reply to comment #1)

> @Edwin Sharp: Can you still reproduce an error with a recent snapshot build?
> Platform is Windows7?

Yes.
Reproduce on
AOO400m1(Build:9700)
2013-05-03 07:08:08 (Fri, 03 May 2013) - Linux x86_64

If this is by design, people will turn off the sidebar when filling cells.
And if they turn it off, they will probably won't bother turn it on again...
Comment 4 Oliver-Rainer Wittmann 2013-05-13 11:35:46 UTC
I can not reproduce the described defect 
- on Ubuntu 10.04 (64bit) with current snapshot build (AOO400m1(Build:9700); 2013-05-03 07:08:08 (Fri, 03 May 2013) - Linux x86_64) 
- on Ubuntu 11.10 (64bit) with former snapshot build (AOO400m1(Build:9700); 2013-05-07 14:38:38 (Tue, 07 May 2013) - Linux x86_64)
- on Windows 7 Pro (64bit) with current snapshot build (AOO400m1(Build:9700)  -  Rev. 1479897)
- on Windows 7 Pro (64bit) with former snapshot build (AOO400m1(Build:9700)  -  Rev. 1478648)

I did the following:
- start OpenOffice
- new spreadsheet document
--> cell A1 is selected and property sidebar shows panels Text, Alignment, Cell Appearance and Number Format are shown.
- start typing/editing
--> edit cell mode started and property sidebar shows panels Text and Alignment
- continue typing/editing
--> no "blinking" in the property sidebar, Text and Alignment panels are shown
- finish typing/editing


@Edwin:
The version information which you were giving is looking like the one from the Linux developer snapshot.
Comment 5 Edwin Sharp 2013-05-13 12:32:21 UTC
This behavior is in both Win and Debian
Very clear in the video:
http://screencast.com/t/1XwUfCT9eI
-while collected data is inserted into sheet the sidebar is constantly changing form and distracting the user.
Maybe this is by design (horrible if yes!) so no one understands me?
Comment 6 Oliver-Rainer Wittmann 2013-05-13 13:02:10 UTC
(In reply to comment #5)
> This behavior is in both Win and Debian
> Very clear in the video:
> http://screencast.com/t/1XwUfCT9eI
> -while collected data is inserted into sheet the sidebar is constantly
> changing form and distracting the user.
> Maybe this is by design (horrible if yes!) so no one understands me?

Thanks for the video.
It shows me that we were not talking about different things.
The video shows several start-editing-end-editing-cycles on different cells.
The current behavior of the property sidebar is intended as we have defined different contexts for just having a cell selection and being in cell edit mode - as Andre already pointed out. For these contexts different property panels are currently defined to be visible.

Edwin, do I understand you correct that you want these two contexts to be unified?
Comment 7 Edwin Sharp 2013-05-13 13:19:06 UTC
Yes.

Maybe if removing some panels and putting others instead - I can understand the logic
But in this case removing for blank space in screen...

Bottom line: erratic working environment = distraction = bad thing.
Comment 8 SVN Robot 2013-05-17 12:26:35 UTC
"af" committed SVN revision 1483767 into trunk:
122219: Show 'Cell Appearance' and 'Number Format' panels when editing cells.
Comment 9 Andre 2013-05-17 12:27:34 UTC
With the video I now understand that 'blinking' means that different sets of panels are displayed.

The task shown in the video (insert text into a cell then go the next cell below) seems to be a frequent use case which would cause the sets of panels to change quite often.  Therefore I made the requested change and added Cell Appearance and Number Format for the "EditCell" context.