Issue 122198 - Color palette should have the same size in sidebar and main UI
Color palette should have the same size in sidebar and main UI
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Armin Le Grand
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-01 10:57 UTC by Hagar Delest
Modified: 2013-07-12 16:37 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Comparison of the 2 color palettes (34.37 KB, image/png)
2013-05-01 10:57 UTC, Hagar Delest
no flags Details
Screenshot of the FontCOlor palette window (33.22 KB, image/png)
2013-05-02 09:02 UTC, Armin Le Grand
no flags Details
Comparison of the 2 color palettes with default palette (40.01 KB, image/png)
2013-05-02 19:14 UTC, Hagar Delest
no flags Details
Screenshot showing palettes (60.54 KB, image/png)
2013-05-03 08:59 UTC, Armin Le Grand
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Hagar Delest 2013-05-01 10:57:51 UTC
Created attachment 80616 [details]
Comparison of the 2 color palettes

If you open the color palette in the main UI (formatting toolbar for example), you get a 10 rows x 11 columns picker.
If you open the color palette in the side bar, you get a 11 rows x 10 columns picker.

The side bar should use the same size so that the rendering is not wrecked when colors are sorted.
See attachment.
Comment 1 Armin Le Grand 2013-05-02 09:02:05 UTC
Created attachment 80620 [details]
Screenshot of the FontCOlor palette window

ALG: Hi Hagar, what version did you use? This is not even the current palette, also not the current formatting. I will create an attachment showing what my current Win version shows. And both are the same in my version, no difference...
Comment 2 Armin Le Grand 2013-05-02 09:02:24 UTC
ALG: Grepping
Comment 3 Armin Le Grand 2013-05-02 16:41:23 UTC
ALG: In the meantime built a current Linux version and the layout is as shown in my last attachment. Thus, I'm closing this task.
Comment 4 Hagar Delest 2013-05-02 19:13:25 UTC
I'm using a custom color palette, see: http://forum.openoffice.org/en/forum/viewtopic.php?f=6&t=14529#p224014

But the problem is easily reproducible. I've reset the profile on my AOO 4 dev version to get the default palette (see attachment). The 2 palettes do not display the same. Do you confirm that when you click the color picker in the font color icon in the sidebar you get exactly the same layout than your screenshot?
Comment 5 Hagar Delest 2013-05-02 19:14:07 UTC
Created attachment 80625 [details]
Comparison of the 2 color palettes with default palette
Comment 6 Armin Le Grand 2013-05-03 08:59:29 UTC
Created attachment 80630 [details]
Screenshot showing palettes

ALG: Hi Hagar, have done this with win version now, downloaded your palette standard.soc and reset user profile. What I get is the 12-field wide new layout in *both* displays, adding a screenshot.
Using this possibility to add a 'ColorValueSetColumnCount' to the user configuration, so when you may use your palette in the future you will be able to change the column count from 12 (the default) to 10 which fits your palette. Caution: This number will influence some layouts in dialogs (e.g. fillstyle), so too high numbers may lead to problems.
The 'ColorValueSetColumnCount' will be in share/registry/main.xcd.
Comment 7 SVN Robot 2013-05-03 09:01:43 UTC
"alg" committed SVN revision 1478676 into trunk:
i122198 added ColorValueSetColumnCount entry to configuration, default is 12
Comment 8 Armin Le Grand 2013-05-03 09:04:30 UTC
ALG: Okay, added, comitted, done. Checked values up to aind including 15 work well.