Issue 122182 - [sidebar] The underline button in the sidebar does both underline and strikethrough
[sidebar] The underline button in the sidebar does both underline and striket...
Status: CLOSED FIXED
Product: General
Classification: Code
Component: code
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-28 08:46 UTC by doucher
Modified: 2013-05-03 19:33 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 4.0.0
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description doucher 2013-04-28 08:46:46 UTC
This issue is easily reproduced.
1. Create a new presentation file and begin to insert text.
2. Select the text and click the "underline" icon on the sidebar.
This results in the selected text being displayed with both "underline" and "strikethrough". It should only be displayed with "underline".

sidebar testcase reported as 'failed' due to this issue: AOOTest-1535.
Comment 1 Oliver-Rainer Wittmann 2013-04-30 06:53:06 UTC
working on a fix
Comment 2 Oliver-Rainer Wittmann 2013-04-30 13:45:14 UTC
The same defect occurs in Writer and in Calc.

Root cause:
Missing <break> in handling click on the controls
Comment 3 SVN Robot 2013-04-30 14:07:37 UTC
"orw" committed SVN revision 1477636 into trunk:
122182: TextPropertyPanel:
Comment 4 Oliver-Rainer Wittmann 2013-04-30 14:14:13 UTC
fixed on trunk for AOO 4.0
Comment 5 Yurggent Alfredo Chable Torrez 2013-05-03 19:33:44 UTC
I have tested with windows 7, ubuntu12.10 and AOO 4.0.0
and it is solved.

Regars

Yurggent Alfredo