Issue 122145 - [sidebar] When selecting two group objects only the PosAndSize toolbar stay open
[sidebar] When selecting two group objects only the PosAndSize toolbar stay open
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: code
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-23 13:49 UTC by Armin Le Grand
Modified: 2013-07-11 13:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Armin Le Grand 2013-04-23 13:49:34 UTC
ALG: With the bugdoc from task #122111# from the original description when selecting both group objects, only PosSize panel stays open; Line, Area, Paragraph and Text get closed. I cannot reproduce this with two self-created groups with e.g. different fill color.
Comment 1 Andre 2013-05-08 09:39:35 UTC
This works as designed.  This multi selection activates the "MultiObject" context, for which only the "Position and Size" and the new "Insert Shapes" panels are displayed.

This can easily be changed but that would be an enhancement and would a proposal of how a better solution should look like.
Comment 2 Armin Le Grand 2013-05-08 11:06:56 UTC
ALG: Seems to have to do with OLE objects; in the example math OLE objects are part of the group objects. Maybe it plays a role here that OLEs can have line/fill/text now, but could not at Symphony. Somewhere at activation this seems to be checked.
@Andre: Multiselection is *not* the problem here, without Math OLEs the multiselection allows the corrcet panels to appear (no diff to single objectselection).
Comment 3 Armin Le Grand 2013-05-08 12:34:00 UTC
ALG: SidebarController::notifyContextChangeEvent gets a rEvent.ContextName only with the mentioned BugDoc, but not when multiple objects or multiple grouped objects are selected.
Comment 4 Armin Le Grand 2013-05-08 13:14:19 UTC
ALG: I would say that SelectionAnalyzer::IsShapeType should add OBJ_OLE2 (and OBJ_FRAME) if with 'ShapeType' is meant that this object can get FillStyle/LineStyle/Paragraph and Text, this would solve the problem and would make the SelectionAnalyzer work correctly when OLEs are involved.
Comment 5 Armin Le Grand 2013-05-15 15:07:25 UTC
ALG: Checking with Crash AOO Color adjustment Zeichnungen.odg...
Comment 6 Armin Le Grand 2013-05-15 16:17:28 UTC
ALG: Two changes:
- In multiselection (or group object selection) OLE is seen as DrawObject to allow draw object context to be detected. This offers the Line/FillStyle panels.
- for single selection of OLEs, Line/FillStyle panels are offered, default is to offer these in their closed state.
Comitting changes...
Comment 7 SVN Robot 2013-05-15 16:23:08 UTC
"alg" committed SVN revision 1482937 into trunk:
i122145 Two changes: Multiselection with mix of DrawObjects and OLE will allo...
Comment 8 Armin Le Grand 2013-05-15 16:47:48 UTC
ALG: Okay, done.