Issue 122144 - [sidebar] Improve sidebar UI
[sidebar] Improve sidebar UI
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
: 122166 (view as issue list)
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-23 11:11 UTC by Andre
Modified: 2013-07-11 13:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2013-04-23 11:11:03 UTC
There are still several small things that need improvement in the sidebar UI.
Comment 1 SVN Robot 2013-04-23 11:41:59 UTC
"af" committed SVN 0 into trunk:
122144: Use AOO icons for flipping shapes.
Comment 2 Andre 2013-04-23 11:46:52 UTC
Icons for flipping shapes horizontally or vertically in the Position and Size panel used Symphony icons.  The buttons now use the icons attached to the uno commands.  Removed the Symphony icons and their references.
Comment 3 Andre 2013-04-23 13:50:52 UTC
Titles of decks and panels are now painted with bold text.
Comment 4 SVN Robot 2013-04-23 13:53:30 UTC
"af" committed SVN 0 into trunk:
122144: Paint titles of sidebar decks and titles bold.
Comment 5 SVN Robot 2013-04-26 07:58:17 UTC
"af" committed SVN 0 into trunk:
122144: Use same color for all sidebar backgrounds.
Comment 6 SVN Robot 2013-04-26 08:06:51 UTC
"af" committed SVN 0 into trunk:
122144: Use same color for all sidebar backgrounds.
Comment 7 Andre 2013-04-26 08:26:35 UTC
Use the same color (dialog color from style settings) for backgrounds of panels, decks and tab bar.
Comment 8 Andre 2013-04-26 08:27:18 UTC
The NumberFormatPropertyPanel uses Symphony icons for number formats.  Use AOO icons instead.
Comment 9 SVN Robot 2013-04-26 08:44:57 UTC
"af" committed SVN 0 into trunk:
122144: Use AOO icons for sidebar number formats.
Comment 10 Andre 2013-04-26 12:04:58 UTC
The ParagraphPropertyPanel still uses a lot of Symphony icons.  Replacing with AOO icons where available and bound to a UNO command.
Comment 11 SVN Robot 2013-04-26 12:22:54 UTC
"af" committed SVN 0 into trunk:
122144: Replace more Symphony icons with AOO icons: ParaPropertyPanel.
Comment 12 Andre 2013-04-26 12:25:51 UTC
*** Issue 122166 has been marked as a duplicate of this issue. ***
Comment 13 Andre 2013-04-26 12:26:55 UTC
Regarding the replaced icons in ParaPropertyPanel see also issue 122166, which did a similar thing.
Comment 14 SVN Robot 2013-04-30 10:57:29 UTC
"af" committed SVN 0 into trunk:
122144: GraphicPropertyPanel: Color mode control now looks like in toolbar.  ...
Comment 15 Andre 2013-04-30 10:59:57 UTC
Changed the color mode control in the Graphic property panel to look like in the toolbar:
- No icons, just text entries.
- Use the same string resources, removed the duplicates.

Fixed a bug of overlapping icons and metric fields that are due to rounding errors of resource coordinates.
Comment 16 Andre 2013-06-17 12:01:27 UTC
Work is done.  Setting to fixed.