Issue 122142 - can't select text in comment of a cell in spreadsheet.
can't select text in comment of a cell in spreadsheet.
Status: RESOLVED FIXED
Product: Calc
Classification: Application
Component: editing
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Armin Le Grand
:
: 122134 (view as issue list)
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-23 07:09 UTC by Du Jing
Modified: 2013-07-12 16:37 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2013-04-23 07:09:33 UTC
Trunk build: r1413470

steps:
1.new a spreadsheet
2.focus a cell and insert a comment
3.input some text in comment box and select all text 

defect:
can't select text in comment box.
Comment 1 Armin Le Grand 2013-04-30 13:57:45 UTC
ALG: The problem is that SC seems to do some extra-repaints in the area used for text edit, using CTRL+ALT+R (for repaint) shows that the text is correct and that a selection is correct, but not correctly displayed. Taking a look...
Comment 2 Armin Le Grand 2013-04-30 14:51:22 UTC
ALG: #122134# may be double to this
Comment 3 Armin Le Grand 2013-05-02 16:16:49 UTC
ALG: problem is the hilighting using handles which use overlay; the OverlayFrame for the slight blinking is not intended to be shown with actiove TextEdit (this will need extended EditEngine stuff so that EE will not directly paint itself to the target window). That CaptionObjects use it is an error.
It can also be reproduced with caption objects directly. I also checked for lines, edges, measures, customshapes and tables due to usage in ImpIsFrameHandles, but only for captions it's as bad as described. To be minimal invasive, do a simple fix this time in handle creation directly in the central handle creation method.
Comment 4 SVN Robot 2013-05-02 16:29:07 UTC
"alg" committed SVN revision 1478430 into trunk:
i122142 do use simple text hilight frame when captions are in TextEdit mode
Comment 5 Armin Le Grand 2013-05-02 16:32:13 UTC
*** Issue 122134 has been marked as a duplicate of this issue. ***
Comment 6 Armin Le Grand 2013-05-02 16:32:38 UTC
ALG: Okay, done.