Issue 122121 - [sidebar]Line panel-line color on sidebar will not be blank when select many different color line.
[sidebar]Line panel-line color on sidebar will not be blank when select many ...
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-22 07:06 UTC by Du Jing
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2013-04-22 07:06:19 UTC
build:

steps:
1.new a document
2.insert two line object,and set different color via side bar
3.select the two line object and check the color box

defect:
the line color don't be blank.
Comment 1 Du Jing 2013-04-22 07:21:15 UTC
Trunk build: r1413470
Comment 2 Armin Le Grand 2013-04-24 11:03:41 UTC
ALG: Missing infos: Application, OS.

Ckecked on Draw/Impress, color shows neutral (white)
Checked in calc, color gets disabled
Checked in Writer, color shows neutral (white)

Intended behaviour is to show neutral color; disabling would not allow to select a color for both selected lines. Checking why calc behaviour is different...
Comment 3 Armin Le Grand 2013-04-24 11:29:22 UTC
ALG: Sc sends a  of SFX_ITEM_DISABLED while the other apps send a SFX_ITEM_DONTCARE (as expected). Checking why Sc sends a SFX_ITEM_DISABLED...
Comment 4 Armin Le Grand 2013-04-24 12:49:57 UTC
ALG: Reason is that in ScDrawShell::GetDrawAttrState the ItemSet fetched from the selected objects is not just copied, but 'Put' to the target ItemSet by using rSet.Put( pDrView->GetAttrFromMarked(sal_False) );. This merges the items using bInvalidAsDefault == true in SfxItemSet::Put, so every item which is on state invalid will be put to state default. Some lines below all defaults for line and fill attr get set from default to disabled. I think the 'Put' should either be replaced by an assignment or be called with bInvalidAsDefault == false, checking...
Comment 5 Armin Le Grand 2013-04-24 13:00:11 UTC
ALG: Works as expected. Also noticed that the LineEnds are not adapted in Sc and Sw when LineWidth changes (as in Draw/Impress and in the LineStyle dialog)...
Comment 6 SVN Robot 2013-04-24 13:10:27 UTC
"alg" committed SVN revision 1471393 into trunk:
i122121 Adapted ScDrawShell::GetDrawAttrState
Comment 7 Armin Le Grand 2013-04-24 15:18:38 UTC
ALG: Comitted. done.
Comment 8 SVN Robot 2013-04-24 15:21:04 UTC
"alg" committed SVN revision 1471471 into trunk:
i122121 moded automatic StartEnd adaption to svx