Issue 122104 - [sidebar] No tab bar button is selected.
[sidebar] No tab bar button is selected.
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: code
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-19 15:19 UTC by Andre
Modified: 2013-07-11 13:56 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2013-04-19 15:19:22 UTC
In certain circumstances there is no tab bar button selected.

How to reproduce:
1. Open a new Writer document.
2. Insert a shape.
3. Deselect the shape.

The button of the property deck should be selected but isn't.
Comment 1 SVN Robot 2013-04-19 15:27:17 UTC
"af" committed SVN revision 1469899 into trunk:
122104: Fixed selection of sidebar button.
Comment 2 Andre 2013-04-19 15:28:29 UTC
On a context switch both the deck and the tab bar are updated.  But there where different optimizations to prevent unnecessary work.  Looks like the tab bar button update was less optimized: the tab bar buttons are sometimes destroyed and created again after the deck is modified.  But the selection of the button for the current deck was updated from within the deck update method.

Fixed by updating the button selection at a better time.