Issue 122096 - [Sidebar]Bullet icon have no effect after click numbering icon
[Sidebar]Bullet icon have no effect after click numbering icon
Status: RESOLVED FIXED
Product: Impress
Classification: Application
Component: editing
4.0.0-dev
All All
: P3 major (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-19 03:43 UTC by Li Feng Wang
Modified: 2013-05-29 08:15 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2013-04-19 03:43:16 UTC
build:r1413470

steps:
1)new a Impress
2)insert a rectangle shape 
3)enter some paragragh in it
4)turn on default numbering on sidebar
5)turn off numbering on sidebar
6)turn on default bullet on sidebar

defect:
have no default bullet display before paragragh on step6.
Comment 1 zhengfan 2013-04-26 03:16:57 UTC
Further more, if keep swithing on/off of bullet, the paragraph will show numbering but not bullets. 
But, such issue is not a sidebar corresponding one, for the previous AOO release without Sidebar feature also have the same issue. Reproduce steps:

New impress and insert retangle;
Active numbering via properties->numbering and bullets;
Disable the numbering;
Active bullets via toolbar->bullets on/off;

The numbering show up again, but no bullets;

Suggest consider this issue as a common one, and remove the keyword 'sidebar' from the summary.
Comment 2 Andre 2013-05-10 13:05:06 UTC
This looks like a problem of using too many slots and concepts for the same thing:
- Numbering seems to be a special case of bullets.
- FN_NUM_BULLET_ON and FN_NUM_NUMBERING_ON toggle bulltes/numbers on/off.
- FN_SVX_SET_BULLET sets the bullet type.
- FN_SVX_SET_NUMBER sets the numbering type.

The bullet handling was already a mess and the sidebar did not improve the situation.  Maybe the bug can be fixed by more carefully coordinating the different slots (set all of them explicitly instead of relying on default handlers for toggling bullets and numbering).

This may be a general problem but the sidebar makes it much more visible so I would like to keep the 'sidebar' keyword for now.  Only if fixing it proves to be too much work for the coming release should we 'demote' it to a general problem that may or may not be fixed in the future.
Comment 3 Armin Le Grand 2013-05-13 11:26:57 UTC
ALG: AFAIR CL adapted the already messed up numbering to standard numbering as in Sw to make the UI look the same; still, internally, it was not really cleanedup, but working with +1/-1 indexes and similar as I recall. A messed up part, not easy to fix.
Comment 4 Armin Le Grand 2013-05-13 13:44:30 UTC
ALG: Cannot reproduce. Tried with selecting a single paragraph (or keep the cursor in it), all paragraphs (in edit mode) or the object (outside edit mode). I always get the correct numbering and after step (6) the correct bullets. This even works without step (5).
Comment 5 Armin Le Grand 2013-05-13 13:48:35 UTC
ALG: Further played around, and when 'turn on default numbering' means to klick the bullets/numbering dropdowns without dropping down, indeed this happens. When dropping down and selecting something this does not happen. Looks as if the 'default' action when klicking the button is not well-defined - it should do the same as selecting one of the dropdown entries (?). If it is intended to delete the bullet(s)/Numbers and only switch B/N on/off so that the defaults from the stlyesheet get used, it may be needed to delete Bullets and Numbering in both actions.
Comment 6 Oliver-Rainer Wittmann 2013-05-22 10:10:03 UTC
taking over in order to evaluate if and how this can be fixed.
Comment 7 SVN Robot 2013-05-29 08:10:49 UTC
"orw" committed SVN revision 1487394 into trunk:
122096: - <OutlinerView::ToggleBullets()> - apply default bullet numbering ru...
Comment 8 Oliver-Rainer Wittmann 2013-05-29 08:15:43 UTC
fixed on trunk for AOO 4.0