Issue 122085 - [Sidebar] Custom animation UI in sidebar the effect text overwrite when switching between animations
[Sidebar] Custom animation UI in sidebar the effect text overwrite when switc...
Status: RESOLVED FIXED
Product: Impress
Classification: Application
Component: ui
4.0.0-dev
All Windows 8
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-18 08:26 UTC by r4zoli
Modified: 2013-07-11 14:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
screenshot_custom_aniamtion (22.85 KB, image/png)
2013-04-18 08:26 UTC, r4zoli
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description r4zoli 2013-04-18 08:26:05 UTC
Created attachment 80543 [details]
screenshot_custom_aniamtion

Custom animation UI in sidebar the effect text overwrite when switching between animations, see attached screenshot.
To reproduce, open any presentation with more than one animation on one page.
Or add two line text and add custom animation both.

Click on one and next second, in sidebar UI the "Effect" text not changes according the selection, both text displayed.Tested under win8, with 1468069 version.
Comment 1 Andre 2013-04-23 13:28:43 UTC
Without looking into the code, the root cause is probably that the fixed text has now a transparent background color (to allow the sidebar controller to define the background color).  When the text is changed, the old text is not painted over with the background color and therefore it is still visible when the new text is displayed.
Comment 2 SVN Robot 2013-04-23 13:56:36 UTC
"af" committed SVN revision 1470963 into trunk:
122085: Fixed over-painting of fixed text.
Comment 3 Andre 2013-04-23 13:57:36 UTC
Fixed by setting the background of all fixed text and fixed lines explicitly to the background color defined in the sidebar::Theme.