Issue 122067 - [sidebar] Selection in number list gallery does not reflect selection
[sidebar] Selection in number list gallery does not reflect selection
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: ui
4.0.0-dev
All All
: P3 minor (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
:
: 122070 (view as issue list)
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-15 18:19 UTC by Rob Weir
Modified: 2013-05-07 14:55 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Rob Weir 2013-04-15 18:19:21 UTC
1. In Writer, add two paragraphs.

2. For the first paragraph, using the Sidebar, apply a numbered list and set the style to be lower case roman numerals (the last option)

3.  For the second paragraph, using using the Sidebar, apply a numbered list and set the style to be upper case Roman letters (the 6th choice).

4.  Now, selecting each paragraph, return to the gallery of number formats.  Note that the highlighted entry in the gallery is the last style applied to *any* paragraph, not the style applied to the current selected paragraph.
Comment 1 Oliver-Rainer Wittmann 2013-04-24 08:46:01 UTC
In my current local environment there is no selection at all in the numbered list popup (and the bullet list popup).

Having now a deeper look.
Comment 2 Oliver-Rainer Wittmann 2013-04-24 09:00:18 UTC
fix in progress
Comment 3 Oliver-Rainer Wittmann 2013-04-24 10:21:41 UTC
fixed on trunk for AOO 4.0
Comment 4 Oliver-Rainer Wittmann 2013-04-24 10:23:28 UTC
*** Issue 122070 has been marked as a duplicate of this issue. ***
Comment 5 SVN Robot 2013-04-24 10:24:04 UTC
"orw" committed SVN revision 1471348 into trunk:
122067: show correct state in paragraph property panel's bullet and numbering...
Comment 6 Shenfeng Liu 2013-05-07 14:55:34 UTC
Verified in build  Rev. 1478648. And it was fixed.