Issue 122057 - [sidebar] Custom tool panel extension "confuses" the sidebar
[sidebar] Custom tool panel extension "confuses" the sidebar
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-04-14 19:38 UTC by Ariel Constenla-Haile
Modified: 2013-07-11 13:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Ariel Constenla-Haile 2013-04-14 19:38:57 UTC
Install the Watching Window extension from http://extensions.openoffice.org/en/project/watchingwindow

or build the extension sample from odk/examples/cpp/custompanel

When an extension providing a custom tool panel UI element is installed, the sidebar gets "confused".
For example, once the sdk demo is installed, open a Writer document. You'll see the custom panel both in the task pane and the sidebar. Following issues in the sidebar:
* the usual icons disappear from the task bar, only "Soylent Green" and "Soylent Red" are shown
* clicking on a tab activates the respective panel, but it "does not work" (you don't see the green/red background)

If tool panel extensions are still supported, looks like they shouldn't be integrated by default in the sidebar.
An extension developer may want to provide a tool panel but not a sidebar panel; this has the advantage that the user might leave the sidebar with the property panel, to manipulate the document; and dock the task pane with the extension panel, thus having both the task pane and the sidebar, for different purposes with different functionality.
Comment 1 Ariel Constenla-Haile 2013-04-14 20:01:09 UTC
Setting the extension developer, Tsutomu Uchino, on Cc.

@Tsutomu: I experience some crashes with the Watching Window on Calc, but didn't have time to do a backtrace and find if they are related to the sidebar.
Comment 2 Andre 2013-04-15 15:09:21 UTC
I am unable to install the WatchingWindow extension.  The extension manager shows a dialog that contains "No module named pythonloader, traceback follows\X000ano traceback available".  The help on http://www.openoffice.org/udk/python/python-bridge.html (point 4) does not help.
Comment 3 Andre 2013-04-15 15:14:50 UTC
Added request to show the legacy sidebar extensions to the old, not the new sidebar, to the wiki page.  Up to now it was my plan to integrate them into the new sidebar and eventually remove the old sidebar.
Comment 4 SVN Robot 2013-05-21 13:29:50 UTC
"af" committed SVN revision 1484803 into trunk:
i122057: Fixed layouting of legacy sidebar panels.
Comment 5 Andre 2013-05-21 13:46:28 UTC
There where two problems:

- The default layout information that is used for all panels that don't provide explicit size information had a maximum height of 0.  This resulted in panels that had height 0 and thus where not visible.
This was caused by a typo: two numbers where listed in the wrong order.

- The mbIsEnabled flag of decks, that controls whether decks are initially visible, where not correctly handled in copy constructors of DeckDescriptor.  This could result in standard panels not being visible.

Fixed both.


Regarding that idea that panels that come from extensions could/should be displayed in the task pane:

This may be so for some developers.  Others may want their panels be displayed in the main sidebar.  We don't know what the majority will want.
For the time being I will display these panels in the main sidebar.

We can think at a later time about whether we need more than one sidebar window.

In any case I will disable the task pane, see bug 122335.