Issue 122010 - Update python to version 2.7.5
Update python to version 2.7.5
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: scripting
4.0.0-dev
All All
: P3 major (vote)
: 4.0.0
Assigned To: jsc
:
: 110637 (view as issue list)
Depends on: 119384
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-07 00:33 UTC by Pedro Giffuni
Modified: 2013-12-30 16:44 UTC (History)
4 users (show)

See Also:
Issue Type: TASK
Latest Confirmation on: 4.0.0
Developer Difficulty: simple


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Pedro Giffuni 2013-04-07 00:33:05 UTC
Python version 2.7.4 was released. This is 2.7 series bugfix release. It includes hundreds of bugfixes over 2.7.3.

http://hg.python.org/cpython/file/9290822f2280/Misc/NEWS

The build system has probably not changed sifnificantly. I would think it is very important to update this before the next AOO release as there are significant improvements for windows and MacOSX.
Comment 1 Pedro Giffuni 2013-04-08 19:52:06 UTC
FWIW, the sources for Python 2.7.4 have been uploaded in Apache Extras to make easier the update.

Updating this should be relatively easy:

- update external_deps.lst
- Update the makefiles in python/
- In python/ edit the patches and prj/d.lst to replace 2.7.3 to 2.7.4
- Fix any breakage from the last step.
Comment 2 Pedro Giffuni 2013-04-08 20:10:44 UTC
(In reply to comment #1)
> FWIW, the sources for Python 2.7.4 have been uploaded in Apache Extras to
> make easier the update.
> 


62704ea0f125923208d84ff0568f7d50-Python-2.7.4.tar.bz2
Comment 3 SVN Robot 2013-04-16 15:56:40 UTC
"jsc" committed SVN revision 1468480 into trunk:
#122010# ensure that python 2.7.4 is used under MacOS
Comment 4 SVN Robot 2013-05-03 05:53:33 UTC
"jsc" committed SVN revision 1478650 into trunk:
#122010# update python to ver 2.7.4
Comment 5 jsc 2013-05-03 06:05:53 UTC
update python version to 2.7.4 and built and tested successful on Linux and Windows.
Comment 6 jsc 2013-05-03 06:30:52 UTC
Linux, Windows and MacOS built and verified
Comment 7 Pedro Giffuni 2013-05-03 11:17:42 UTC
(In reply to comment #3)
> "jsc" committed SVN revision 1468480 into trunk:
> #122010# ensure that python 2.7.4 is used under MacOS

FWIW, I still think that system python 2.7.1 in MacOS
should be used if it is available.

Thank you for updating the internal python, I am sure
it will be inportant for many users :).
Comment 8 jsc 2013-05-22 13:43:27 UTC
reopen and used to update on 2.7.5 which fixed some regressions
Comment 9 jsc 2013-05-22 13:44:38 UTC
version 2.7.5 is uploaded on extras for convenience

6334b666b7ff2038c761d7b27ba699c1-Python-2.7.5.tar.bz2
Comment 10 SVN Robot 2013-05-23 11:53:52 UTC
"jsc" committed SVN revision 1485654 into trunk:
#122010# prepare configur to support Python 2.7.5 and newer on MacOS, 2.7.1 i...
Comment 11 SVN Robot 2013-05-23 17:34:04 UTC
"jsc" committed SVN revision 1485784 into trunk:
#122010# prepare configure to support Python 2.7.5 and newer on MacOS, 2.7.1 ...
Comment 12 SVN Robot 2013-06-03 08:15:43 UTC
"jsc" committed SVN revision 1488886 into trunk:
#122010# update Python to 2.7.5
Comment 13 jsc 2013-06-03 09:42:00 UTC
fixed on trunk
Comment 14 SVN Robot 2013-06-03 17:37:49 UTC
"jsc" committed SVN revision 1489073 into tags/SNAPSHOT:
#122010# update d.lst
Comment 15 SVN Robot 2013-06-03 17:47:14 UTC
"jsc" committed SVN revision 1489077 into trunk:
#122010# update d.lst
Comment 16 hanya 2013-06-04 12:46:41 UTC
After the update to Python 2.7.5, it can not be started up on Linux 32bit.
Here is part of the traceback: 
  File "/mnt/hd/ooo/main/instsetoo_native/unxlngi6.pro/Apache_OpenOffice/installed/install/en-US/openoffice4/program/python-core-2.7.5/lib/sysconfig.py", line 352, in _init_posix
    from _sysconfigdata import build_time_vars
ImportError: No module named _sysconfigdata

_sysconfigdata file is generated during the building of Python since Python 2.7.5 [1], back ported from 3.X. 

[1] http://bugs.python.org/issue13150

Maybe all library files should be copied from python-inst.

Index: python/prj/d.lst
===================================================================
--- python/prj/d.lst	(revision 1489281)
+++ python/prj/d.lst	(working copy)
@@ -73,6 +73,7 @@
 ..\%__SRC%\misc\build\Python-2.7.5\Lib\multiprocessing\dummy\* %_DEST%\lib%_EXT%\python\multiprocessing\dummy\*
 ..\%__SRC%\misc\build\Python-2.7.5\Lib\unittest\* %_DEST%\lib%_EXT%\python\unittest\*
 ..\%__SRC%\misc\build\Python-2.7.5\Makefile %_DEST%\lib%_EXT%\python\python2.7\config\Makefile
+..\%__SRC%\misc\build\python-inst\lib\python2.7\_sysconfigdata.py %_DEST%\lib%_EXT%\python\_sysconfigdata.py
 
 ..\pyversion.mk %_DEST%\inc%_EXT%\pyversion.mk
Comment 17 jsc 2013-06-04 16:11:15 UTC
 hanya: do you know more about this? I have delivered sysconfigdata and rebuildpyuno but it still crashed.
Comment 18 hanya 2013-06-04 16:20:25 UTC
@jsc: did you rebuild pyuno module? Python files are delivered from python module 
and after that, pyuno/zipcore takes care them again.
_sysconfigdata.py file should be there in solver/xxx/lib/python/lib and 
pyuno/xxx/bin/python-core-version/lib (and also zipped package).
Comment 19 jsc 2013-06-04 16:27:12 UTC
yes I rebuild pyuno but it's seems that my build contained some old stuff, now it works
Comment 20 SVN Robot 2013-06-04 16:30:13 UTC
"jsc" committed SVN revision 1489507 into trunk:
#122010# deliver _sysconfigdata.py
Comment 21 jsc 2013-06-11 10:51:35 UTC
fixed
Comment 22 hanya 2013-12-30 16:44:12 UTC
*** Issue 110637 has been marked as a duplicate of this issue. ***