Issue 121981 - [sidebar] Table Design section does not display in sidebar
[sidebar] Table Design section does not display in sidebar
Status: RESOLVED FIXED
Product: Impress
Classification: Application
Component: ui
4.0.0-dev
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-03-31 12:09 UTC by Edwin Sharp
Modified: 2013-07-11 14:41 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Edwin Sharp 2013-03-31 12:09:15 UTC
While executing Test Case ID AOOTest-1151
Table Design section does not display in sidebar
Comment 1 liuyixuan.527 2013-04-10 01:29:08 UTC
It is caused by sample files not containing a table. So, this is not a defect!
Comment 2 Edwin Sharp 2013-04-10 05:08:45 UTC
Yes it is a defect!
The file is containing a table.
Please see link:
http://screencast.com/t/J574HRLMVB
Comment 3 Ariel Constenla-Haile 2013-04-11 14:45:03 UTC
Confirmed on current trunk.
It's like the panel appears for some seconds when you move through the table with the keyword arrows.
Comment 4 Andre 2013-04-12 14:37:38 UTC
Thanks for the video.  It shows that the context changes when the cursor is moved from one cell to the next from Table to DrawText.  That should not happen.
Comment 5 ipark321 2013-04-19 06:53:47 UTC
sorry.. changed status on wrong bug..
Comment 6 Shenfeng Liu 2013-04-19 17:06:20 UTC
When I create a table in Presentation and check the table design panel, my AOO crash. It was reproduced also in 2 other people's machines (all Win 7).
So I'd like to raise this defect to P1/Blocker.
Comment 7 Ariel Constenla-Haile 2013-04-19 17:09:40 UTC
(In reply to comment #6)
> When I create a table in Presentation and check the table design panel, my
> AOO crash. It was reproduced also in 2 other people's machines (all Win 7).
> So I'd like to raise this defect to P1/Blocker.

This is bug 122095
Comment 8 Ariel Constenla-Haile 2013-04-19 17:11:48 UTC
Resetting fields.
The crash is a different bug.
Comment 9 Shenfeng Liu 2013-04-19 17:15:18 UTC
Arial,
  Thanks to create the new defect! I will move my comments to 122095.
Comment 10 Shenfeng Liu 2013-04-19 17:21:58 UTC
Oh, I should say thanks for Li Feng to report the defect!
Comment 11 Oliver-Rainer Wittmann 2013-05-02 10:53:08 UTC
described defect no longer reproducible in current snapshot build.
--> resolving issue as irreproducible.

Edwin Sharp: Can you please confirm that the defect no longer occurs in recent snapshot build? If not, please reopen this issue.
Comment 12 Edwin Sharp 2013-05-02 12:13:43 UTC
Apologies Oliver.
Problem as seen in comment 2 persists in Rev. 1476029
Comment 13 Oliver-Rainer Wittmann 2013-05-02 12:42:11 UTC
(In reply to comment #12)
> Apologies Oliver.
> Problem as seen in comment 2 persists in Rev. 1476029

No, I have to apologize - it is not my day today.

You are right - the defect still occurs
Comment 14 Edwin Sharp 2013-05-09 18:38:41 UTC
Test Case ID AOOTest-1143 :: Version : 1 

Rev. 1479897

Bug persists
Comment 15 SVN Robot 2013-05-13 15:28:53 UTC
"af" committed SVN revision 1481916 into trunk:
121981: Don't change sidebar context while in Impress table.
Comment 16 Andre 2013-05-13 15:29:24 UTC
Fixing this by adding a special case to SelectionAnalyzer::GetContextForSelection_SD():
When text editing is active then still return 'Table' as context when the object that is being edited is a table.

Also removed some code from DrawViewShell::GetContextForSelection() (sd/source/ui/view/drviewsa.cxx) that also handled the case of text editing.  This should not be necessary because GetContextForSelection_SD() handles this case as well, the one I modified as outlined above.