Issue 121933 - hide/view invade whole panel when docked above/below another panel
hide/view invade whole panel when docked above/below another panel
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All Linux64
: P3 normal (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-22 08:31 UTC by Hagar Delest
Modified: 2013-04-05 11:27 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Hagar Delest 2013-03-22 08:31:17 UTC
OS: Ubuntu 12.10 64bit
AOO350m1(Build:9611)  -  Rev. 1458754

Dock Navigator or Stylist on the right side of the window (could not reproduce on left side...).
Dock Sidebar below the first panel (better reproducible when below even if some occurrence when above...)
Uncheck View>Sidebar to hide it
Check View>Sidebar and the Sidebar takes quite all the place and reduces the first panel to a tiny area.
Comment 1 Andre 2013-03-22 15:24:40 UTC
Taking over.
Comment 2 Andre 2013-03-25 14:02:07 UTC
I can reproduce this bug.  It works in both ways: disable the navigator (hit F5) and enable it again (another F5) and this time the sidebar ends up small.

The same works with navigator and stylist. Hide the sidebar and press F5, then F11.  Arrange both controls one above the other and play with hitting F5 and F11.
Eventually one control will become rather small.

This is probably a bug in the framework layouting code.  I am not sure if I will find the time to fix this for 4.0.
Comment 3 Oliver-Rainer Wittmann 2013-04-03 10:16:50 UTC
I tried AOO 3.4.1 and trunk (0).
First, I could not reproduce the described behavior with Navigator and Stylist. But after I changed the size of the Navigator or/and the Stylist the described behavior occurs.

Thus, I agree with Andre that this issue is a general one independent of the changes for the sidebar feature
--> removing block on bug 121420 and adjusting summary.
Comment 4 Oliver-Rainer Wittmann 2013-04-05 10:04:27 UTC
I had a look and figured out some improvements.
It will not be the ultimate solution, but i should improve the layout of the docked windows in a undock-dock-cycle of a certain window.

Changes will be committed soon.
Comment 5 SVN Robot 2013-04-05 11:24:50 UTC
"orw" committed SVN 0 into trunk:
#121933# - some improvement to the docking area layout on a undock-dock-cycle...
Comment 6 Oliver-Rainer Wittmann 2013-04-05 11:27:29 UTC
solved/improved dock area layout on undock-dock-cycle of a certain window on trunk for AOO 4.0