Issue 121880 - Find and Replace fails unless case is matched
Find and Replace fails unless case is matched
Status: VERIFIED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 critical with 2 votes (vote)
: 4.0.0
Assigned To: hdu@apache.org
: oooqa, regression
: 122553 122567 (view as issue list)
Depends on:
Blocks: 121633
  Show dependency treegraph
 
Reported: 2013-03-11 17:55 UTC by Shari
Modified: 2013-08-01 13:51 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 4.0.0
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+


Attachments
Proposed patch to fix this problem (1.45 KB, patch)
2013-06-04 17:15 UTC, hanya
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Shari 2013-03-11 17:55:29 UTC
Find is not finding what is search for, unless the correct case is used whether correct case is ticked or not.

I downloaded the latest nightly build to verify it was still happening.

You must match case for it to find what you are searching for.

I confirmed this for both cal and writer.

Here is a screen cast showing it in action.
http://screencast.com/t/NPduEn4EZn

Version information:
AOO400m1(Build:9700)  -  Rev. 1454390
Rev.1452047
Comment 1 Edwin Sharp 2013-03-15 11:45:23 UTC
Find is successful regardless of case in "Search for" field when "Match case" is unchecked.
Rev. 1400866
Comment 2 Shari 2013-04-05 21:18:31 UTC
I think your rev number is for the 3.x version. I'm working in the 4.x version. Can someone verify that it is or isn't working in the 4.x version.

Thanks!
Comment 3 Rob Weir 2013-04-05 22:53:00 UTC
Works in AOO 3.4.1, but Shari indicates it is broken in the 4.0 trunk.

I'm confirming and raising priority since this is a regression.

Thanks!
Comment 4 Ariel Constenla-Haile 2013-04-06 10:43:08 UTC
Adding regression keyword.
Comment 5 Edwin Sharp 2013-04-06 18:36:27 UTC
Same as comment 1 with Rev. 1458754 in Debian.
Comment 6 Rainer Bielefeld 2013-05-06 04:19:54 UTC
Still Reproducible with Rev.1476029
OS = All due to Comment 5
Comment 7 hanya 2013-05-06 08:29:39 UTC
It seems this is happen after changes by issue 121633.
When I use older value of SIMPLE_TRANS_MASK changed in revision 1436862, 
the match case options seems working.
Comment 8 hanya 2013-06-04 17:15:11 UTC
Created attachment 80772 [details]
Proposed patch to fix this problem

To use different mask for regexp flag.
Comment 9 Andre 2013-06-18 11:01:39 UTC
*** Issue 122553 has been marked as a duplicate of this issue. ***
Comment 10 Andre 2013-06-21 06:50:22 UTC
*** Issue 122567 has been marked as a duplicate of this issue. ***
Comment 11 jsc 2013-06-21 08:19:07 UTC
set showstopper flag
Comment 12 SVN Robot 2013-06-24 14:55:16 UTC
"hdu" committed SVN revision 1496073 into trunk:
#i121880# fix case-sensitive non-regexp text search
Comment 13 hdu@apache.org 2013-06-24 14:57:10 UTC
Many thanks to Hanya for the patch!
Comment 14 Edwin Sharp 2013-06-24 16:42:41 UTC
(In reply to hdu from comment #13)
> Many thanks to Hanya for the patch!

+1
Comment 15 Shari 2013-07-05 16:23:59 UTC
Thank you! I just installed:
AOO400m3(Build:9702)  -  Rev. 1499427
Rev.1497734

And the search is working!!!
Yippy!
Comment 16 fanyuzhen 2013-07-10 10:55:06 UTC
I change bug status to Verified/Fixed per testing from Shari in comment 15