Issue 121823 - update serf to new version 1.2.1
update serf to new version 1.2.1
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: code
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-25 14:41 UTC by jsc
Modified: 2013-07-26 13:07 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Patch to update serf to 1.2.0 (4.80 KB, patch)
2013-02-25 14:59 UTC, Ariel Constenla-Haile
no flags Details | Diff
Win Patch (4.72 KB, patch)
2013-02-26 07:09 UTC, Ariel Constenla-Haile
no flags Details | Diff
Enable serf logging, on *nix (2.29 KB, patch)
2013-02-26 07:30 UTC, Ariel Constenla-Haile
no flags Details | Diff
Patch to update serf to 1.2.1 (12.20 KB, patch)
2013-06-12 23:36 UTC, Ariel Constenla-Haile
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description jsc 2013-02-25 14:41:18 UTC
The update to the new serf version seems to fix also some existing issues.
Comment 1 Ariel Constenla-Haile 2013-02-25 14:59:21 UTC
Created attachment 80357 [details]
Patch to update serf to 1.2.0
Comment 2 jsc 2013-02-25 16:16:20 UTC
does it mean that you have the update already done?
Comment 3 Ariel Constenla-Haile 2013-02-25 16:20:09 UTC
(In reply to comment #2)
> does it mean that you have the update already done?

It means it is a patch, only tested on Linux (but should work on the other platforms, too). Before breaking the build bots, it's better to test the patch on Windows before committing it (I can build on Win when I'm back home at the afternoon).
Comment 4 jsc 2013-02-25 16:24:31 UTC
ok perfect, I will test it on Mac
Comment 5 jsc 2013-02-25 17:00:50 UTC
MacOS seems to work, serf and ucb build at least. Will test the office tomorrow...
Comment 6 Ariel Constenla-Haile 2013-02-26 07:09:55 UTC
Created attachment 80362 [details]
Win Patch

Windows patch for updating serf to 1.2.0
(Tested on Windows 7, 64 bits)
Comment 7 Ariel Constenla-Haile 2013-02-26 07:30:28 UTC
Created attachment 80363 [details]
Enable serf logging, on *nix

Logging goes to stderr, so enabled only on *nix when exporting ENABLE_SERF_LOGGING=YES
Comment 8 Ariel Constenla-Haile 2013-03-02 22:09:10 UTC
IMHO updating to serf 1.2.0 does not introduce (serious) regressions.

Bug 121844 and bug 121845 seem to be discovered thanks to updating serf (instead of being caused by this update); in AOO 3.4.1 they are impossible to reproduce because serf does not work at all (in these two cases).
Comment 9 Ariel Constenla-Haile 2013-03-03 14:27:02 UTC
Removing blocker status for bug 121202 (updating to serf solves some bug but not all of them), they should be investigated and fixed independently.
Comment 10 SVN Robot 2013-03-03 14:57:07 UTC
"arielch" committed SVN 0 into trunk:
i121823 - update serf to new version 1.2.0
Comment 11 Ariel Constenla-Haile 2013-06-12 17:17:50 UTC
Reusing this one for further update to 1.2.1
Comment 12 Ariel Constenla-Haile 2013-06-12 23:36:44 UTC
Created attachment 80843 [details]
Patch to update serf to 1.2.1
Comment 13 Ariel Constenla-Haile 2013-06-12 23:37:47 UTC
(In reply to Ariel Constenla-Haile from comment #12)
> Created attachment 80843 [details]
> Patch to update serf to 1.2.1

@jsc: can you try this on MacOS?
I tried it on Linux/Windows and works fine.
Comment 14 hdu@apache.org 2013-07-10 11:18:50 UTC
Looking at the change log at http://serf.googlecode.com/svn/tags/1.2.1/CHANGES and the release comment that it "fixes a number of bugs, including a pretty bad bug in digest authentication on a single, shared connection (issue 102)" this should be considered for inclusion into AOO 4.0.0
Comment 15 jsc 2013-07-10 11:20:11 UTC
grant showstopper flag
Comment 16 SVN Robot 2013-07-10 11:26:42 UTC
"arielch" committed SVN 0 into trunk:
i121823 - Update serf to new version 1.2.1
Comment 17 hdu@apache.org 2013-07-10 11:27:54 UTC
It already got in but the issue status wasn't updated.
Comment 18 Ariel Constenla-Haile 2013-07-12 11:34:05 UTC
(In reply to hdu@apache.org from comment #17)
> It already got in but the issue status wasn't updated.

blame it on the SVN Robot that forgot to remind me to do so.

@jsc: release blocker flag has no sense on this bug, it will appear in the Bug List:"4.0.0_release_blocker+, Resolved", "normal" QA volunteer will have no idea how to verify this.
Comment 19 jsc 2013-07-12 11:42:44 UTC
it felt in my automatism, hdu checked, we have overseen that it was already integrated -> grant the flag to integrate ...

we can just verify and close
Comment 20 SVN Robot 2013-07-26 12:35:14 UTC
"hdu" committed SVN 0 into trunk:
#i121823# the update to serf-1.2.* obsoleted the serf-1.0 tarball
Comment 21 SVN Robot 2013-07-26 13:07:27 UTC
"hdu" committed SVN 0 into trunk:
#i121823# the update to serf-1.2.* obsoleted the serf-1.1 tarball