Issue 121788 - [sidebar]: migrate area property Panel (W,C,I)
[sidebar]: migrate area property Panel (W,C,I)
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Armin Le Grand
:
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-02-19 09:30 UTC by jsc
Modified: 2013-07-11 13:56 UTC (History)
2 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jsc 2013-02-19 09:30:51 UTC
migrate area property panel (W,C,I) 

svx/source/propertypanel/areapropertypage.cxx 

See also 
http://wiki.openoffice.org/wiki/Sidebar#Decks_and_content_panels
Comment 1 Armin Le Grand 2013-02-25 14:14:35 UTC
ALG: Taking over...
Comment 2 Armin Le Grand 2013-02-25 15:20:28 UTC
ALG: First rough migration done, looking for missing slots for transparency (SID_ATTR_FILL_TRANSPARENCE, SID_ATTR_FILL_FLOATTRANSPARENCE) and how to implement these...
Comment 3 Armin Le Grand 2013-02-26 17:24:19 UTC
ALG: Got the transparency slots triggered now after adding SID_ATTR_FILL_TRANSPARENCE, SID_ATTR_FILL_FLOATTRANSPARENCE as slots. Implementing reaction on these...
Comment 4 Armin Le Grand 2013-02-26 17:25:23 UTC
ALG: Implemented own handlers for these slots, checked, works now. Transparency works, except the Syphony popups for color and transparency gradient (when transparency gradient is selected).
Comment 5 Armin Le Grand 2013-03-19 11:58:40 UTC
ALG: Back on the AreaPropertyPanel. Thanks to Andre for providing and adapting the popups in the meantime.
Works pretty well now. Found one fault: When using one of the transparence gradients, the popup closes too early, it should stay open until the user ends editing it. Looking into it...
Comment 6 Armin Le Grand 2013-03-19 12:03:28 UTC
ALG: Found and changed. Found another problem: All changes lead to one undo action. What should happen is that e.g. changing the transparency gradient should create one undo action when the manipulation by the user ends, else the undo stack is pretty useless and the user looses valuable information in the undos. This is a general problem, e.g. this also happens when changing object position, not only in sidebar but also when just moving the object with the keyboard. This may be solved by combining actions of the same kind on the undo stack. Looking into this...
Comment 7 Armin Le Grand 2013-03-19 12:04:17 UTC
ALG: AreaPropertyPanel itself is pretty complete now.
Comment 8 SVN Robot 2013-03-19 12:06:07 UTC
"alg" committed SVN revision 1458237 into branches/sidebar:
i121788 corrected popup time of AreaTransparencyGradientPopup so that it stay...
Comment 9 Armin Le Grand 2013-03-20 10:37:16 UTC
ALG: Added https://issues.apache.org/ooo/show_bug.cgi?id=121924 for the undo problem to handle it later and not forget it. For now, continuing with the panel.
Comment 10 Armin Le Grand 2013-03-20 11:11:33 UTC
ALG: When the TransparenceGradients go to 100% for start and end value, transparency jumps from completely transparent to not transparent. For all transparency gradient types. Also reproducable with current dialog. Taking a look...
Comment 11 Armin Le Grand 2013-03-20 12:05:49 UTC
ALG: Okay, found and corrected, checking in.
Comment 12 SVN Robot 2013-03-20 12:09:16 UTC
"alg" committed SVN revision 1458779 into branches/sidebar:
i121788 corrected handling of TransparenceGradients when start/end values are...
Comment 13 Armin Le Grand 2013-03-20 14:05:16 UTC
ALG: Another problem: When object selected (e.g. ellipse, blue, fill color), then changing FillStyle in toolbar to gradient, then *not* seleting a gradient value, then in panel select another color -> wild previews in the Toolbar's AreaStyle/Filling preview and in that dropdown list get created. This is due to the two-step FillStyle change action in the toolbar, there was previous no possibility as now in panel to change value in the in-between state. Checking what to do...
Comment 14 Armin Le Grand 2013-03-20 14:08:30 UTC
ALG: Corrected in SvxFillToolBoxControl, comitting...
Comment 15 SVN Robot 2013-03-20 14:09:39 UTC
"alg" committed SVN revision 1458836 into branches/sidebar:
i121788 In SvxFillToolBoxControl always correct selected FillStyle list entry...
Comment 16 SVN Robot 2013-03-20 16:42:20 UTC
"alg" committed SVN revision 1458937 into branches/sidebar:
i121788 Avoided assertion (GroupProperties::GetObjectItemSet() should never b...
Comment 17 Armin Le Grand 2013-03-30 18:25:57 UTC
ALG: Working well, done so far.
Comment 18 SVN Robot 2013-04-12 09:49:47 UTC
"orw" committed SVN revision 1467226 into trunk:
121788: - remove duplicate resource introduced by accident