Issue 121625 - (profile-caused-crash) Tracking issue for AOO 3.4 startup related crashes
(profile-caused-crash)
Tracking issue for AOO 3.4 startup related crashes
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: code
3.4.1
All All
: P2 normal (vote)
: 4.0.0
Assigned To: Oliver-Rainer Wittmann
:
: 116964 120025 120068 120227 120337 120362 120540 120728 120980 121149 121203 121345 121594 121629 121662 121756 121778 121783 122296 (view as issue list)
Depends on:
Blocks: 120013 120886 118217 120068 120154 120227 120728 120980 121203 121229 121309 121592 121594 121629 121673
  Show dependency treegraph
 
Reported: 2013-01-15 09:46 UTC by hdu@apache.org
Modified: 2013-07-23 08:08 UTC (History)
22 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Windows Vista is affected too (18.59 KB, application/vnd.oasis.opendocument.text)
2013-02-13 10:45 UTC, Joep Frensen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2013-01-15 09:46:13 UTC
This issue is for tracking the mysterious crashes that seem to happen a couple of seconds after starting OpenOffice. These issues is that they are usually quite light on the details but they are so frequent as to point to a really bad problem.

The scenario seems to happen especially on WinXP and seems to be solved by disabling the update service, by deleting the user profile and by downgrading from IE9 to IE8.
Comment 1 hdu@apache.org 2013-01-15 09:59:38 UTC
There are hints that the problem is related to the update service:
- the stack mentioning updchk.dll (http://de.openoffice.info/viewtopic.php?f=3&t=48659#p178132 and http://www.justanswer.com/computer/5dao5-when-start-open-office-unsaved-document.html) 
- disabling the update service seems to fix it (http://forum.openoffice.org/en/forum/viewtopic.php?f=15&t=55912&start=30#p258626 and http://forum.openoffice.org/en/forum/viewtopic.php?f=15&t=58275)
similar crash happens with OOo3.3 if IE9 is installed (https://issues.apache.org/ooo/show_bug.cgi?id=117907)
- Stephan Bergmann mentioned in http://ooo-forums.apache.org/en/forum/viewtopic.php?t=55017&p=242599#p242632 a very interesting observation regarding InternetQueryOption() that could point to the root cause
Comment 2 Oliver-Rainer Wittmann 2013-01-15 10:08:24 UTC
CC myself
Comment 3 hdu@apache.org 2013-01-15 10:40:07 UTC
Adding a few more related issues to the "blocked by" list.
Bug 118246 also mentions "Updates for extensions available" before the crash.
Comment 4 Rob Weir 2013-02-02 02:09:02 UTC
*** Issue 121149 has been marked as a duplicate of this issue. ***
Comment 5 Rob Weir 2013-02-13 01:56:38 UTC
*** Issue 120728 has been marked as a duplicate of this issue. ***
Comment 6 Joep Frensen 2013-02-13 10:45:58 UTC
Created attachment 80268 [details]
Windows Vista is affected too

This bug appears in Windows Vista TOO! See attached document. It is a bug that makes this version of OO hard to use if you need a document soon. It is ONLY seen (by me) with the FIRST document opened in an OO session.
Comment 7 Oliver-Rainer Wittmann 2013-02-15 11:14:09 UTC
I was able to reproduce crashes of AOO 3.4 and AOO 3.4.1 which are upgrades of a former OOo 3.3 installation.

The problem is caused by the OOo 3.3 bundled extensions - namely three dictionaries - which are not correctly migrated. The AOO 3.4/3.4.1 installation process more or less "removes" the intrinsic bundled extensions. Only their folders (found in the installation folder) and the extension database entries (found in the user profile as Berkeley DBs) are left. The extension database entries are imported into the new extension database format. Thus, regarding these bundled extensions the state is inconsistent.
The crashes are triggered when the extensions are accessed in order to check for updates. The check for extension updates can be performed manually or is triggered by the automatic check for an application update, if the check for an application update is configured respectively.

The problem persists even, if the user profile has been renamed/removed. This is causes by the still existing bundled extension folders. These folders "let the office think" that such bundled extensions are available. Thus corresponding extension database entries are created during the startup after the user profile had been renamed/removed. This results more or less in the same inconsistent state as above.

A possible workaround is to remove the following files from the user profile:
- $USERPROFILE/3/user/extensions/bundled/extensions.pmap 
- $USERPROFILE/3/user/extensions/bundled/extensions.db, if it exists.
Comment 8 Oliver-Rainer Wittmann 2013-02-15 12:07:09 UTC
The C++ internal root cause of the crashes I observed is that certain functions/methods accessing extensions do not handle thrown C++ exception.

Thus, I will commit a patch which will just catch these C++ exceptions.
Comment 9 SVN Robot 2013-02-15 13:28:08 UTC
"orw" committed SVN revision 1446574 into trunk:
#121625# - method <ExtensionManager::getExtensionsWithSameId(..)> - catch cer...
Comment 10 Rob Weir 2013-02-15 19:35:00 UTC
*** Issue 121756 has been marked as a duplicate of this issue. ***
Comment 11 Oliver-Rainer Wittmann 2013-02-18 09:16:49 UTC
*** Issue 121783 has been marked as a duplicate of this issue. ***
Comment 12 Oliver-Rainer Wittmann 2013-02-18 09:25:23 UTC
*** Issue 121778 has been marked as a duplicate of this issue. ***
Comment 13 Suchithra 2013-02-18 18:48:34 UTC
*** Issue 121629 has been marked as a duplicate of this issue. ***
Comment 14 Rob Weir 2013-02-24 21:31:22 UTC
*** Issue 121662 has been marked as a duplicate of this issue. ***
Comment 15 Rob Weir 2013-02-24 21:33:07 UTC
*** Issue 121345 has been marked as a duplicate of this issue. ***
Comment 16 Rob Weir 2013-03-05 02:27:45 UTC
*** Issue 121594 has been marked as a duplicate of this issue. ***
Comment 17 Rob Weir 2013-03-05 02:28:33 UTC
*** Issue 121203 has been marked as a duplicate of this issue. ***
Comment 18 Oliver-Rainer Wittmann 2013-03-12 11:01:42 UTC
damn - I have forgotten to mark this issue as FIXED.
Comment 19 Rob Weir 2013-03-21 19:52:03 UTC
*** Issue 120025 has been marked as a duplicate of this issue. ***
Comment 20 Rob Weir 2013-04-02 23:53:54 UTC
*** Issue 120362 has been marked as a duplicate of this issue. ***
Comment 21 Rob Weir 2013-04-03 00:00:11 UTC
*** Issue 120337 has been marked as a duplicate of this issue. ***
Comment 22 Rob Weir 2013-04-03 14:29:31 UTC
*** Issue 120540 has been marked as a duplicate of this issue. ***
Comment 23 Rob Weir 2013-04-03 14:50:29 UTC
*** Issue 120068 has been marked as a duplicate of this issue. ***
Comment 24 Ariel Constenla-Haile 2013-05-12 14:01:47 UTC
*** Issue 122296 has been marked as a duplicate of this issue. ***
Comment 25 Oliver-Rainer Wittmann 2013-06-06 08:51:41 UTC
*** Issue 120227 has been marked as a duplicate of this issue. ***
Comment 26 Oliver-Rainer Wittmann 2013-06-14 10:05:45 UTC
*** Issue 120980 has been marked as a duplicate of this issue. ***
Comment 27 hdu@apache.org 2013-07-23 08:08:16 UTC
*** Issue 116964 has been marked as a duplicate of this issue. ***