Issue 121538 - Disable UI "fontwork" for custom shapes
Disable UI "fontwork" for custom shapes
Status: RESOLVED FIXED
Product: Draw
Classification: Application
Component: ui
4.0.0-dev
Mac Mac OSX, 10.6
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-22 17:48 UTC by Regina Henschel
Modified: 2013-07-12 16:33 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 3.4.1
Developer Difficulty: ---


Attachments
Tools to reproduce the bug (110.61 KB, image/png)
2013-01-31 20:12 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2012-12-22 17:48:07 UTC
Add the command "Fontwork" to the toolbar. It is in category "Format".

Draw a custom shape, for example a triangle from the category "Basic Shapes".

Add a text to the shape (key F2, then write).

Click on the "Fontwork"-icon and select type "Rotate". You will see the text is now along the edges of the bounding box.

Save the document and reload it. Notice, that the text is again horizontal in its default position.

Custom shapes are not able, to show the text along a path using this command. This command can only work on the "classical" objects like Bezier curves, but not on custom shapes. For custom shapes this kind of "along path" cannot be saved and this information is lost on save. Therefore this command should not be available, if a custom shape is selected.
Comment 1 Suchithra 2013-01-31 19:39:04 UTC
This issue is not reproducible on Mac OSX 10.6.8.
Comment 2 Regina Henschel 2013-01-31 20:11:06 UTC
I see the problem still in AOO3.5 on Windows. I have attached a picture, to show which tool I use.
Comment 3 Regina Henschel 2013-01-31 20:12:00 UTC
Created attachment 80186 [details]
Tools to reproduce the bug
Comment 4 Armin Le Grand 2013-04-09 10:55:54 UTC
ALG: Taking a look...
Comment 5 Armin Le Grand 2013-04-09 11:36:35 UTC
ALG: Disablings happen in sd and sc, adding code there to also disable on CustomShape selection.
Adding Regina to CC.
@Regina: Do you know if it*'s possible to get that dialog in SW, if yes, disabling should be missing completely. I hope it's not possible to get it in Writer.
Comment 6 Armin Le Grand 2013-04-09 12:14:12 UTC
ALG: Found, can be activated in SW, too. Also found the slot executors for deactivation, adding code for disabling when CustomShapes are selected...
Comment 7 SVN Robot 2013-04-09 12:22:48 UTC
"alg" committed SVN revision 1465991 into trunk:
i121538 Disable FontWork dialog entries (slots) when CustomShapes are selecte...
Comment 8 Armin Le Grand 2013-04-09 13:36:42 UTC
ALG: Okay, done. Checking if it is complicated to remove the forms control from the FontWork dialog. It's a bad thing; users see that dialog the first time and 'test/experiment' what it does by selectiong that form. Since these forms *replace* the originally selected shape and only rescue it's text, it's probably never what they expected. They may never use that dialog again, at least that's my interpretation of it being not very popular since it can do amazing things (text along the geometric definition of your shape, even with multiple paragraphs, etc.). It only makes sense when startin with a form and text and then starting FontWork. Lets see how difficult it is...
Comment 9 SVN Robot 2013-04-09 17:06:33 UTC
"alg" committed SVN revision 1466132 into trunk:
i121538 Removed old Fontwork dialogs preset box and all dependencies
Comment 10 Armin Le Grand 2013-04-09 17:06:55 UTC
ALG: Removal works well, checked and rebuilt from svx. All dependencies removed, too. Checked in r1466132, done.