Issue 121277 - Calc crashes while generating a diagram
Calc crashes while generating a diagram
Status: VERIFIED FIXED
Product: Calc
Classification: Application
Component: editing
3.4.1
PC Windows 7
: P3 major (vote)
: 4.0.0
Assigned To: AOO issues mailing list
Nika
:
: 121276 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-26 01:13 UTC by Hans W. Zekl
Modified: 2013-07-12 16:29 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+


Attachments
Data file which crashes Calc (445.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-26 01:15 UTC, Hans W. Zekl
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Hans W. Zekl 2012-10-26 01:13:19 UTC
When I try to generate a diagram from data of two rows Calc crashes without generating a failure report. 

The uploaded file contains several filters and except of two all other columns are hidden.
Comment 1 Hans W. Zekl 2012-10-26 01:15:40 UTC
Created attachment 79822 [details]
Data file which crashes Calc
Comment 2 Marcus 2012-10-26 18:59:26 UTC
*** Issue 121276 has been marked as a duplicate of this issue. ***
Comment 3 DanielAlvaro 2013-04-24 15:05:43 UTC
Hello Hans,

I repdroduced in win 7 64 and I found the same problem.

I going to confirm this bug and This will be verified

Regards.
Daniel Alvaro
Comment 4 Rob Weir 2013-06-07 01:03:30 UTC
How to reproduce on AOO 3.4/1 with Windows 7 (32-bit)

1) Load attached ODS document into Calc

2) Select the first two visible rows of data with your house, i.e., A1:F32

(Note that filters are enabled that are hiding many of the rows)

3) Menu:  Insert/Chart.  AOO crashes immediately and presents the document recovery dialog.
Comment 5 Armin Le Grand 2013-06-20 11:55:12 UTC
ALG: Taking a look. Also crashes when not selecting the labels. Seems to have to do with getting chart visualization early, but maybe also simply a chart bug.
Comment 6 Armin Le Grand 2013-06-20 13:01:48 UTC
ALG: Indeed a chart bug, in ChartView::createShapes() the usage of lcl_getExplicitSimpleCategories (used during AxisLabel creation) contained some cases where accesses to non-existing stl::vector entries could happen (and did happen) under these circumstances. Fixing this solves the crash and creates the correct chart. Checking some more (chart types, scenarios), preparing commit...
Comment 7 Armin Le Grand 2013-06-20 13:19:57 UTC
ALG: Okay, comitted, done.
Comment 8 jsc 2013-07-03 09:49:25 UTC
grant showstopper flag to get clear status, already fixed
Comment 9 fanyuzhen 2013-07-10 07:57:57 UTC
It's verified fixed in revision 1499347