Issue 121256 - Crash when saving ppt
Crash when saving ppt
Status: VERIFIED FIXED
Product: Impress
Classification: Application
Component: save-export
4.0.0-dev
All All
: P2 major (vote)
: 4.0.0
Assigned To: Andre
: automation_bug
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-23 08:18 UTC by Li Lin Yi
Modified: 2013-07-11 08:18 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 4.0.0_release_blocker+


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Li Lin Yi 2012-10-23 08:18:53 UTC
Sample file: https://svn.apache.org/repos/asf/incubator/ooo/trunk/test/testgui/data/pvt/complex_100p.ppt

Step:
1. Open AOO.
2. Open sample file. Save it as ppt file.

AOO crashed.

AOO341, r1372282, also has this problem.

Found by automation test: Performance Verification Test.
Comment 1 hdu@apache.org 2012-10-24 13:55:56 UTC
Cannot reproduce neither on MacOSX and nor on Linux64/RHEL6 with the current AOO350-dev (trunk rev 1401613)
Comment 2 Li Lin Yi 2012-10-25 05:51:03 UTC
To make this defect more clearer:
Defect found on ubuntu12.04, 32bit. It is OK on ubuntu12.04 64bit.
Comment 3 Kay 2013-06-08 23:56:17 UTC
Confirmed on opensuse 12.1, 32 bit, with AOO4dev.

Opens but does not save.
Comment 4 Andre 2013-06-17 15:41:01 UTC
I can reproduce this bug on Windows7 64bit.  OpenOffice is, of course, 32bit.  This should make debugging easier.
Comment 5 Andre 2013-06-17 15:42:01 UTC
Changing title and Hardware to reflect that this is not a Linux only bug.
Comment 6 Andre 2013-06-21 09:08:45 UTC
Taking over.
Comment 7 Andre 2013-06-21 09:57:53 UTC
Crash is triggered in EscherPropertyContainer::CreateCustomShapeProperties() when saving path coordinates.
The crash is caused by temporarily storing a pointer reference to a PropertyValue and using this pointer outside the scope of the referenced value.  When the inner scope is left then the referenced value disappears.  Accessing its value through the pointer fails.

Fixed by storing the Any of the PropertyValue.Value by value instead of by reference.  Did that for pPathCoordinatesProp which caused this crash and for pAdjustmentValuesProp which had the same problem but was not triggered by the bug doc.

Revision of the fix is 1495357.
Comment 8 jsc 2013-07-03 09:49:08 UTC
grant showstopper flag to get clear status, already fixed
Comment 9 fanyuzhen 2013-07-10 06:58:08 UTC
Checked with revision 1499347 on Ubuntu12.04, 32bit and Windows7, 64bit, do not see the crash