Issue 121126 - [From Symphony]User-definded format code is lost with a cell which value is TRUE or FALSE when importing xls file
[From Symphony]User-definded format code is lost with a cell which value is T...
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: open-import
3.4.1
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
: ms_interoperability
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-27 06:04 UTC by Yan Ji
Modified: 2012-10-18 06:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (25.00 KB, application/vnd.ms-excel)
2012-09-27 06:04 UTC, Yan Ji
no flags Details
Add patch (3.10 KB, patch)
2012-09-27 06:13 UTC, Zhang Lu
zhanglu.aoo: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-09-27 06:04:56 UTC
Created attachment 79654 [details]
sample

Build: AOO 3.4.1
OS: All

Open attached sample file.

Defect:  User-defined format code of A5:B5  is lost.  The format code is [BLUE]#,##0.00;[RED]\(#,##0.00\);[YELLOW]0;[GREEN]@
Comment 1 Zhang Lu 2012-09-27 06:13:29 UTC
Created attachment 79655 [details]
Add patch

Root Cause:
Original number format code has been replaced by BOOL format code after load this kind of formula cell if whose type is boolcell.

Resolution:
Keep the original number format code. Get formula type, if meet logical formula, get result and show TEXT "true" or "false" with original number format.
Comment 2 Wang Lei 2012-09-27 06:58:54 UTC
The patch looks good. Submit it in revision 1390864
Comment 3 Shan Zhu 2012-10-08 09:19:46 UTC
Verified on AOO350m1 1391367. Passed.
Comment 4 Shenfeng Liu 2012-10-18 06:07:50 UTC
Update Target Milestone to AOO 3.5.0.