Issue 121101 - AOO crash when unrecognized bullets&numbering of .pptx files save .odp and reopen
AOO crash when unrecognized bullets&numbering of .pptx files save .odp and re...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
: interop_OOXML
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 06:06 UTC by liuping
Modified: 2013-04-23 07:11 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
unrecognized bullets&numbering in .pptx file (39.82 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-09-28 03:37 UTC, liuping
no flags Details
unrecognized bullets&numbering.PNG (43.38 KB, image/png)
2012-09-28 03:38 UTC, liuping
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-09-26 06:06:09 UTC
Build info:AOO3.5_r1387482
OS: win7-64 bit

produce steps:
1.launch AOO and open the sample file(the file size too large and don't upload)
2.save to .odp and reopen in AOO

Expected Result: .odp open normally 
Actual Result:.odp crash
symphony don't have this problem

SYmphony build info:Release 3.0.1 FP1  Revision 20120830.2232
Comment 1 liuping 2012-09-26 09:00:21 UTC
file name-springl09.pptx
Comment 2 liuping 2012-09-28 03:36:57 UTC
I analy the complicated and multi-slide in pptx file ,find the reason which lead to crash
AOO crash when unrecognized bullets&numbering of .pptx files save .odp and reopen
I simplify the original sample file  and upload the analyed sample file and snapshot picture(unrecognized bullets&numbering.pptx &unrecognized bullets&numbering.png)
Comment 3 liuping 2012-09-28 03:37:50 UTC
Created attachment 79669 [details]
unrecognized bullets&numbering in .pptx file
Comment 4 liuping 2012-09-28 03:38:48 UTC
Created attachment 79670 [details]
unrecognized bullets&numbering.PNG
Comment 5 Regina Henschel 2012-11-11 13:40:11 UTC
The original pptx shows a circled number. Such number belongs to the "East Asian Writing" group of numbering types. AOO 3.4.1 on WinXP does not crash. Therefore I guess, that it is the same problem as issue 121139.
Comment 6 Oliver-Rainer Wittmann 2012-11-19 10:16:04 UTC
same root cause as bug 121139 --> solved now.
Comment 7 binguo 2012-11-28 09:34:17 UTC
Verified on Aoo_Trunk_20121123.1915 Rev.1412533, no crash when open .odp file in AOO, this bug is fixed.
Comment 8 binguo 2012-11-28 09:34:50 UTC
close it.
Comment 9 SVN Robot 2013-04-22 15:39:07 UTC
"jsc" committed SVN revision 1470584 into trunk:
#121101# consolidate directory entries, remove empty name/placeholder dirs
Comment 10 SVN Robot 2013-04-23 07:11:28 UTC
"jsc" committed SVN revision 1470584 into trunk:
#121101# consolidate directory entries, remove empty name/placeholder dirs