Issue 121090 - Draw delete part of closed polygon on saving
Draw delete part of closed polygon on saving
Status: RESOLVED FIXED
Product: Draw
Classification: Application
Component: save-export
3.4.1
All All
: P4 minor (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 121089 121091 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 07:58 UTC by Risto Jääskeläinen
Modified: 2013-07-12 16:24 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Correct tile, what users expect. (4.79 KB, application/vnd.oasis.opendocument.graphics)
2012-09-24 08:45 UTC, Risto Jääskeläinen
no flags Details
Fault file or drawing (8.18 KB, application/vnd.oasis.opendocument.graphics)
2012-09-24 08:47 UTC, Risto Jääskeläinen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Risto Jääskeläinen 2012-09-24 07:58:03 UTC
I have district border drawing made by Inscape and saved as .odg file. (See attachment testiinscape.odg) When I open it to AOO draw, it is quit normal closed border drawing.  But after saving and reloading it is missing at least one part of line. I suppose it is last part of border. (See a attachment testiAOO.odg). Same phenomen happens when I convert some border drawing in Draw.

I think this is small but annoying fault.
Comment 1 Risto Jääskeläinen 2012-09-24 08:45:57 UTC
Created attachment 79627 [details]
Correct tile, what users expect.
Comment 2 Risto Jääskeläinen 2012-09-24 08:47:07 UTC
Created attachment 79628 [details]
Fault file or drawing
Comment 3 Risto Jääskeläinen 2012-09-24 11:53:25 UTC
*** Issue 121089 has been marked as a duplicate of this issue. ***
Comment 4 Regina Henschel 2012-09-24 12:04:46 UTC
*** Issue 121091 has been marked as a duplicate of this issue. ***
Comment 5 Regina Henschel 2012-09-24 12:34:57 UTC
The object is not closed. You can notice this, when you try to fill it. You can close the object from its context menu.

I see the problem with the attached document. It remains after ungrouping the object. I cannot reproduce it with a new document.
Comment 6 Armin Le Grand 2012-09-24 16:13:39 UTC
ALG: At polygon export time (SdXMLImExSvgDElement::AddPolygon) there is code which reduces the polygon for equal start/end points; this should only be done when the polygon *is* closed. Good catch! Anyways, that code in xexptran.cxx should be replaced with using the basegfx tooling nowadays.
Checking...
Comment 7 Armin Le Grand 2012-09-24 16:24:42 UTC
ALG: Looks good. Committing...
Comment 8 Armin Le Grand 2012-09-24 16:26:50 UTC
ALG: Okay, done.