Issue 121071 - [Regression]Item lists are incorrectly imported into AOO in DataPilot table
[Regression]Item lists are incorrectly imported into AOO in DataPilot table
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: open-import
4.0.0-dev
All All
: P3 major (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 09:01 UTC by Terry Yang
Modified: 2013-07-12 11:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sample file (7.00 KB, application/vnd.ms-excel)
2012-09-20 09:01 UTC, Terry Yang
no flags Details
Root cause analysis of 121071.odt (58.71 KB, application/vnd.oasis.opendocument.text)
2012-09-21 05:34 UTC, Jianyuan Li
no flags Details
Patch for this issue (4.08 KB, patch)
2012-09-21 05:34 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Terry Yang 2012-09-20 09:01:15 UTC
Created attachment 79589 [details]
Sample file

Build:AOO 3.5 Trunk r1387482

1. Launch AOO then open the attached sample file.
2. Click down arrow of "A"cell button in DataPilot table
3. Check the list items     
	
Actual Result:"test" is selected.

Expect Result:Same as in excel,"test" is unselected.

It is work fine in OO 3.3
Comment 1 Jianyuan Li 2012-09-20 09:22:51 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-09-21 05:33:23 UTC
Root cause and resolution in attachment file "Root cause analysis of 121071.odt"
Comment 3 Jianyuan Li 2012-09-21 05:34:05 UTC
Created attachment 79594 [details]
Root cause analysis of 121071.odt
Comment 4 Jianyuan Li 2012-09-21 05:34:49 UTC
Created attachment 79595 [details]
Patch for this issue
Comment 5 Jianyuan Li 2012-09-21 05:42:14 UTC
Actually AOO only supports importing pivot field item with type string. But after the fix for bug 120839, the only supported one does not work too. My fix focus on the regression issue.
Comment 6 sunying 2012-09-25 02:16:59 UTC
greate work, reviewed.
Comment 7 Jianyuan Li 2012-09-25 05:57:27 UTC
Committed in revision 1389716.
Comment 8 Jianyuan Li 2012-09-25 06:00:06 UTC
Fixed.
Comment 9 Terry Yang 2012-09-27 09:16:03 UTC
Verify fixed on AOO 3.5 Trunk r1390312