Issue 121058 - [From Symphony]To open a sample file contains chart with large data source can lead to AOO crash
[From Symphony]To open a sample file contains chart with large data source ca...
Status: VERIFIED FIXED
Product: Calc
Classification: Application
Component: open-import
3.4.1
All All
: P3 major (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks: 122822
  Show dependency treegraph
 
Reported: 2012-09-20 02:31 UTC by Clarence GUO
Modified: 2013-07-25 13:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
patch (2.25 KB, application/octet-stream)
2012-09-21 06:43 UTC, Clarence GUO
clarence.guo.bj: review?
Details
sample file (490.57 KB, application/octet-stream)
2012-09-21 07:06 UTC, Clarence GUO
clarence.guo.bj: review?
Details

Note You need to log in before you can comment on or make changes to this issue.
Description Clarence GUO 2012-09-20 02:31:37 UTC
Open the sample file with large chart, it takes too much time on loading, looks like freeze. And sometimes a warning dialog pops up with warning msg "Main memory shortage. Please quit other applications or close some windows before continuing.", click "OK" button on this dialog, then pops up an error dialog and AOO crashes.
Comment 1 Clarence GUO 2012-09-21 06:43:50 UTC
Created attachment 79598 [details]
patch

Root Cause:
There are 66000 points in the chart. When draw so many points, it consume too much memory.

Solution:
If there are too many points, picked some points to paint.
Comment 2 Clarence GUO 2012-09-21 07:06:58 UTC
Created attachment 79599 [details]
sample file

Add sample file
Comment 3 Wang Lei 2012-09-21 11:40:00 UTC
This solution is not a total solution to improve chart rendering performance for very larger data.

It is a walkaround. When the number of data point for a data series is larger than 10000, we only sample some data point. It only works for numeric data, not work for text data.
Comment 4 Wang Lei 2012-09-21 11:44:46 UTC
Submit in  revision 1388440
Comment 5 Wang Lei 2012-09-21 11:45:51 UTC
The code looks good. Thanks Clarence GUO
Comment 6 Shan Zhu 2012-10-08 09:31:06 UTC
Verified on AOO350m1 1391367. Passed.