Issue 120979 - Install/bundle msvcr100.dll to improve Java compatibility
Install/bundle msvcr100.dll to improve Java compatibility
Status: VERIFIED FIXED
Product: Installation
Classification: Application
Component: ui
3.4.1
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
:
: 120996 121232 121278 (view as issue list)
Depends on:
Blocks: 119525 123810
  Show dependency treegraph
 
Reported: 2012-09-16 20:59 UTC by Andrea Pescetti
Modified: 2013-12-05 16:57 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andrea Pescetti 2012-09-16 20:59:26 UTC
After discussions on ooo-dev and on the forums, it's now clear that many issues about "corrupt Java/JRE" are related to a missing msvcr100.dll library.

This DLL is included in Microsoft Visual C++ 2010 Redistributable Package (x86) and actually it's Java that requires it, not OpenOffice itself.

But including it would solve Java-related issues for many users.

Context provided on ooo-dev:
- http://user.services.openoffice.org/en/forum/viewtopic.php?f=15&t=56141 (forum discussion with analysis)
- http://www.duckware.com/tech/java6msvcr71.html (technical discussion)
- http://download.microsoft.com/download/5/B/C/5BC5DBB3-652D-4DCE-B14A-475AB85EEF6E/vcredist_x86.exe (redistributable package)
- http://www.mail-archive.com/ooo-dev@incubator.apache.org/msg25691.html (a patch by Ariel with an alternative approach, but this would simply hide the non-working JRE from the list)
Comment 1 Ariel Constenla-Haile 2012-09-23 03:30:13 UTC
Fixed in revision 1388588
Comment 2 Ariel Constenla-Haile 2012-09-23 04:03:04 UTC
Please verify with http://people.apache.org/~arielch/packages/r1388877/win/Apache_OpenOffice_incubating-Dev_AOO350m1_Win_x86_install_en-US.exe
It installs as OOo-Dev, it will not override your current installation.
Comment 3 Andrea Pescetti 2012-09-25 19:53:36 UTC
*** Issue 120996 has been marked as a duplicate of this issue. ***
Comment 4 Andrea Pescetti 2012-09-25 21:10:15 UTC
Verified working by volunteers on the ooo-progetto-it list.
Comment 5 Ariel Constenla-Haile 2012-10-26 03:00:39 UTC
*** Issue 121278 has been marked as a duplicate of this issue. ***
Comment 6 Ariel Constenla-Haile 2012-11-03 22:07:24 UTC
*** Issue 121232 has been marked as a duplicate of this issue. ***