Issue 120967 - A complex table displays wrongly when inserting columns to table of a .ppt file in AOO
A complex table displays wrongly when inserting columns to table of a .ppt fi...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
: ms_interoperability
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 06:15 UTC by liuping
Modified: 2013-07-12 10:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
1.ppt (21.50 KB, application/vnd.ms-powerpoint)
2012-09-14 06:15 UTC, liuping
no flags Details
defect screenshot (1.28 KB, image/png)
2012-09-17 07:05 UTC, sunying
no flags Details
patch for export table rect (2.35 KB, patch)
2012-09-18 06:18 UTC, sunying
sunying: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-09-14 06:15:20 UTC
Created attachment 79503 [details]
1.ppt

Build info:AOO3.5_r1384214

OS: Win7 64 bit 
 
Reproduce steps:
1. Launch Symphony2.0, then open the 1.ppt file, 
2. Check the table
3.Click the cell with red color and choose "table->insert columns right"
4.Save it as another ppt document and open it, then check the table
5.open the saved .ppt document in powerpoint2003, then check the table

Expected Result: same with  MS PowerPoint
Actual Result:insert column disappear and table size become larger

Please refer the capture.png
Comment 1 sunying 2012-09-17 06:00:56 UTC
I'm checking this issue.
Comment 2 sunying 2012-09-17 07:05:08 UTC
Created attachment 79531 [details]
defect screenshot

Another reproduce steps:
1. Open AOO,create a presention.
2. Choose "Insert->Table",create a 2*2 table.
3.Click the 2rd cell and choose "table->insert columns right"
4.Save it as ppt document.
5.Open it in powerpoint2003, then check the table, found the virtual box of table is smaller than the actual table,refer the attachment "defect screenshot.png".
Comment 3 sunying 2012-09-18 06:03:03 UTC
Root cause:
 Table's rectangle write error.
Comment 4 sunying 2012-09-18 06:18:44 UTC
Created attachment 79546 [details]
patch for export table rect

 Solution:
 update table's rectangle when export table.
Comment 5 Jianyuan Li 2012-09-19 08:35:09 UTC
Review OK.
Comment 6 sunying 2012-09-25 02:42:57 UTC
#120967# fix table's virtual box become small when save .ppt file
Reported by: Liu Ping Tan
Patch by: Ying Sun
Review by: Jian Yuan Li
Comment 7 sunying 2012-09-25 02:44:04 UTC
version:1389689
Comment 8 sunying 2012-09-25 07:13:27 UTC
fixed.
Comment 9 louqle 2012-11-06 06:30:59 UTC
verified on Win7 64-bit and 32-bit against trunk build 1404513, pass