Issue 120962 - [From Symphony]Chart data lost if the source data refers to a range name which is defined as a reference formula
[From Symphony]Chart data lost if the source data refers to a range name whic...
Status: VERIFIED FIXED
Product: Calc
Classification: Application
Component: open-import
3.4.0
All All
: P3 major (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 02:43 UTC by Clarence GUO
Modified: 2012-10-08 09:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sample (33.50 KB, application/octet-stream)
2012-09-14 02:43 UTC, Clarence GUO
no flags Details
patch (11.65 KB, patch)
2012-09-21 03:34 UTC, Clarence GUO
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Clarence GUO 2012-09-14 02:43:23 UTC
Created attachment 79498 [details]
Sample

Open the sample Xls file, the chart becomes empty.

The reason is the data series was refered to a range name, while the name was defined as a reference formula. However, AOO only support simple range like "Sheet1.A1:B4".
Comment 1 Clarence GUO 2012-09-21 03:34:44 UTC
Created attachment 79593 [details]
patch

Root Cause:
The data series was refered to a range name, which was defined a reference formula. However, AOO only support simple range like "Sheet1.A1:B4"

Solution:
Remember the referenced token during formula intepretion, then translate the source range from formula name to ScToken.
Comment 2 Clarence GUO 2012-09-21 05:06:10 UTC
This fix is indeed a feature gap. Chart of AOO doesn't support range name which use a reference formula, not only in UI, but also in core function and filter.
Although it needs a total solution to make the feature available, I still want this temporary solution at a bug fix level because it needs some time to implement. The fix will translate a range name which use a reference formula to a actural range. So that means after saving, the range instead of the formula will be saved, the original formula will be lost.
Comment 3 SVN Robot 2012-09-21 06:40:48 UTC
"leiw" committed SVN revision 1388342 into trunk:
#i120962 Chart data lost if the source data refers to a range name which is d...
Comment 4 Wang Lei 2012-09-21 06:52:50 UTC
Submit in revision 1388342
Comment 5 Shan Zhu 2012-10-08 09:26:59 UTC
Verified on AOO350m1 1391367. Passed.