Issue 120927 - Import/Export Hyperlink Info of Graphic with Anchor Type Except “As Character” to MS Word Binary File
Import/Export Hyperlink Info of Graphic with Anchor Type Except “As Character...
Status: VERIFIED FIXED
Product: Writer
Classification: Application
Component: save-export
4.0.0-dev
All All
: P3 major (vote)
: 4.0.0
Assigned To: kang jane
:
Depends on: 120568
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 01:46 UTC by Jian Hong Cheng
Modified: 2013-07-11 08:48 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: 3.4.1
Developer Difficulty: ---


Attachments
Fix for the issue that can't import/export Hyperlink of graphic & frame for Doc binary file. (24.23 KB, application/octet-stream)
2012-10-10 08:55 UTC, kang jane
no flags Details
Reviewed and Updated Patch (23.52 KB, patch)
2012-11-30 02:01 UTC, Jian Hong Cheng
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Jian Hong Cheng 2012-09-13 01:46:56 UTC
Export Hyperlink Info of Graphic with Anchor Type Except “As Character” to MS Word Binary File
Comment 1 kang jane 2012-10-10 08:55:23 UTC
Created attachment 79756 [details]
Fix for the issue that can't import/export Hyperlink of graphic & frame for Doc binary file.

Root cause:
Current in OO doesn't  support import/export Hyperlink of graphic&frame from MS binary file.

Solution:
Add feature for import/export Hyperlink of graphic & frame from MS binary file.

Unit test:
1. Doc save as doc:
   a. Test on Frame with bookmark link, URL, File location, Target Frame, Frame name.
   b. Test on graphic with bookmark link, URL, File location, Target Frame, name.

2. Odt save as doc:
   a. Test on Frame with bookmark link, URL, File location, Target Frame, Frame name.
   b. Test on graphic with bookmark link, URL, File location, Target Frame, name.
Comment 2 Jian Hong Cheng 2012-11-30 02:01:50 UTC
Created attachment 79969 [details]
Reviewed and Updated Patch

Reviewed and Updated Patch
Comment 3 SVN Robot 2012-11-30 08:31:06 UTC
"chengjh" committed SVN revision 1415477 into trunk:
Fix issue #120927: Import/Export Hyperlink Info of Graphic with Anchor Type E...
Comment 4 hdu@apache.org 2012-11-30 09:12:42 UTC
All our buildbots noticed a build breaker introduced by this change:

In file included from main/sw/source/filter/ww8/rtfattributeoutput.cxx:29:
main/sw/source/filter/ww8/ww8par.hxx: In function 'ReturnType ulimit_cast(Type)':
main/sw/source/filter/ww8/ww8par.hxx:383: error: 'numeric_limits' is not a member of 'std'
main/sw/source/filter/ww8/ww8par.hxx:383: error: expected primary-expression before '>' token
main/sw/source/filter/ww8/ww8par.hxx:383: error: '::max' has not been declared
Comment 5 hdu@apache.org 2012-11-30 09:19:49 UTC
and another compiler error was:
  main/sw/source/filter/ww8/wrtw8esh.cxx:2312:6: error: jump to case label [-fpermissive]
  main/sw/source/filter/ww8/wrtw8esh.cxx:2287:23: error: crosses initialization of 'const SdrObject* pSdrObj'
or the same error by a different compiler:
  main/sw/source/filter/ww8/wrtw8esh.cxx(2312) : error C2361: initialization of 'pSdrObj' is skipped by 'default' label
        main/sw/source/filter/ww8/wrtw8esh.cxx(2287) : see declaration of 'pSdrObj'
Comment 6 Jian Hong Cheng 2012-11-30 11:03:31 UTC
which platform the build breaks appear?
Comment 7 hdu@apache.org 2012-11-30 11:55:28 UTC
The Linux32, Linux64 and Windows buildbots complained
http://ci.apache.org/builders/openoffice-linux32-nightly/builds/331
http://ci.apache.org/builders/openoffice-linux64-nightly/builds/438
http://ci.apache.org/builders/aoo-win7/builds/403

On the other hand I'm no longer sure whether your commit or the warning removals such as revision 1415336 were the reason.
Comment 8 SVN Robot 2012-11-30 13:31:15 UTC
"hdu" committed SVN revision 1415625 into trunk:
#i120927# limit scope of case-specific pSdrObj
Comment 9 SVN Robot 2012-11-30 17:06:37 UTC
"hdu" committed SVN revision 1415741 into trunk:
#i120927# ww8par.hxx always needs the numeric_limits include
Comment 10 hdu@apache.org 2012-11-30 17:09:27 UTC
The numeric_limits build problems were fixed with revision 1415741.

The build problems described in comment 5 were not directly related to the original change (revision 1415477), but were introduced by the followup change (revision 1415336). These are fixed now with revision 1415625.
Comment 11 Jian Hong Cheng 2012-12-01 00:38:23 UTC
Thanks to hdu,we should be careful of the compile difference with platform..