Issue 120848 - [From Symphony]"Fit shape to text" property not work after openning ppt by AOO
[From Symphony]"Fit shape to text" property not work after openning ppt by AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 08:50 UTC by Li Feng Wang
Modified: 2012-10-18 07:04 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (59.00 KB, application/vnd.ms-powerpoint)
2012-09-07 08:50 UTC, Li Feng Wang
no flags Details
Text rect comparison between MS and Aoo (86.32 KB, image/jpeg)
2012-09-10 06:40 UTC, Jianyuan Li
no flags Details
Patch for this issue (818 bytes, patch)
2012-09-10 06:41 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff
Why shape size is adjusted with my patch (180.12 KB, application/vnd.oasis.opendocument.text)
2012-09-13 08:28 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Li Feng Wang 2012-09-07 08:50:43 UTC
Created attachment 79351 [details]
sample file

build:
AOO trunk r1378003

steps:
1)open ppt sample file with AOO
2)check text in arrow shape

expected result:
text in shape can fit automatically.

actual result:
text is out of shape, the "Fit shape to text" property not work normally.
Comment 1 Jianyuan Li 2012-09-07 09:12:46 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-09-10 06:39:28 UTC
Root cause: Notched right arrow text rectangular geometry is not defined reasonably.
Resolution: Modify its text rectangular definition.
Notes: A comparison for text rect in MS and AOO can be seen in attachment "comparison.jpg". To compare the the text rect, set "Fix shape to text" first. You will see MS text rect is more reasonable.
Comment 3 Jianyuan Li 2012-09-10 06:40:34 UTC
Created attachment 79373 [details]
Text rect comparison between MS and Aoo
Comment 4 Jianyuan Li 2012-09-10 06:41:38 UTC
Created attachment 79374 [details]
Patch for this issue
Comment 5 Armin Le Grand 2012-09-12 06:37:09 UTC
ALG: I have reviewed this patch. It solves the problem, but there is also a egression introduced: When editing the text shape, the yellow controller is working mirrored in the Y-Direcion. Please correct this, it does not happen with the original shape.
Comment 6 Jianyuan Li 2012-09-12 07:59:41 UTC
@Armin:
Can you provide more detail info for reproducing the regression issue?
Comment 7 Armin Le Grand 2012-09-13 01:52:48 UTC
ALG: Yes. As written. when you select the object (Handles visible) you have one yellow handle. This can be moved hor/ver to change object shape. Horizontal movement works unchanged, but vertical movement is inverted when the patch is applied. It works as expected without the patch. HTH!
Comment 8 Jianyuan Li 2012-09-13 03:39:55 UTC
With my path, no matter how I changed the shape with the yellow handle, I cannot make it inverted. Can you provide a snapshot for your inverted yellow handle?
Comment 9 Armin Le Grand 2012-09-13 06:28:40 UTC
ALG: No, i would have to provide a movie to show this, it happens during interaction. It's not about inversion of the object itself.
When you move the yellow handle upward, the shape gets smaller vertically. It should get bigger, as without the patch.
When you move the yellow handle down, the shape gets bigger vertically. It should get smaller, as without the patch.
I can demonstrate life if needed...
Comment 10 Jianyuan Li 2012-09-13 08:28:21 UTC
Created attachment 79478 [details]
Why shape size is adjusted with my patch
Comment 11 Jianyuan Li 2012-09-13 08:36:44 UTC
@Armin:
Getting bigger or smaller is indeed related to my patch. Because text rect is adjusted in my fix and "Fit shape to text" is set for the shape in sample file. This two points result in the change. See my analysis in attachment "Why shape size is adjusted with my patch".
I think this behavior is acceptable. You can check another shape "striped right arrow". It also works like that when moving the handle(set property "Fit shape to text" for shape).
What's your opinion?
Comment 12 Armin Le Grand 2012-09-13 09:21:19 UTC
ALG: I tried striped right arrow and you are correct. It also happens with right arrow. It is a general effect when 'resize shape to fit text' is activated. When thinking about it it seems logical; when the shape is resized to the text after the new position is adapted, the position *has* to move again. It is not a good user feedback, but the control (the yellow handle) cannot stay where the mouse pointer is positioned.
I agree, it's acceptable behaviour and could only be fixed/changed in a more general way. Maybe moving the handles when interaction is done is a solution. The handle would be shown on its true new position, not under the mouse pointer. This would at least make clear to the user what happens.
Thus, review is done. Shall I commit your change?
Comment 13 Jianyuan Li 2012-09-13 09:30:38 UTC
@Armin:
Yes, please go ahead. Thanks.
Comment 14 SVN Robot 2012-09-14 01:52:11 UTC
"alg" committed SVN revision 1384629 into trunk:
#120848# Added correct text content frame for NotchedRightArrow AutoshapePatc...
Comment 15 Armin Le Grand 2012-09-14 01:52:42 UTC
ALG: Okay, done. Thanks for the patch!
Comment 16 Armin Le Grand 2012-09-14 01:53:06 UTC
ALG: Setting to fixed
Comment 17 Li Feng Wang 2012-09-18 08:27:31 UTC
text in shape can fit automatically.
Comment 18 Shenfeng Liu 2012-10-18 07:04:00 UTC
Update Target Milestone to AOO 3.5.0.