Issue 120718 - [From Symphony]after save the sample file with page border and shadow to doc, the shadow depth and color changed
[From Symphony]after save the sample file with page border and shadow to doc,...
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: save-export
4.0.0-dev
All All
: P3 normal (vote)
: 4.0.0
Assigned To: zhengfan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 05:37 UTC by zong dong jun
Modified: 2013-05-21 11:16 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (251.79 KB, application/vnd.oasis.opendocument.text)
2012-08-27 05:37 UTC, zong dong jun
no flags Details
The patch for reivew (499 bytes, patch)
2012-08-30 06:13 UTC, zhengfan
zheng.easyfan: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description zong dong jun 2012-08-27 05:37:21 UTC
Created attachment 79158 [details]
sample file

Build:
AOO350m1(Build:9610)

Steps:
1.open the sample in Aoo and save it to .doc file, 
2.Open the new  saved .doc file in AOO,

Defect:  the page border's shadow depth and color changed.
Comment 1 xiao ting xiao 2012-08-28 01:34:52 UTC
it can reproduce in AOO341 0
Comment 2 zhengfan 2012-08-30 06:12:14 UTC
I will take this issue.
Comment 3 zhengfan 2012-08-30 06:13:40 UTC
Created attachment 79224 [details]
The patch for reivew
Comment 4 zhengfan 2012-08-30 08:34:17 UTC
The shadow color one is caused by the limitation of MS Word DOC format, which do not support the shadow color as AOO did. So this issue will focus on the shadow width problem only.
Comment 5 Jian Hong Cheng 2012-08-31 11:08:09 UTC
Reviewed and Committed with revision::1379417
Comment 6 Du Jing 2012-09-04 06:33:39 UTC
verify fail on the build AOO3.5_r1380171

the shadow width change to 0.02 from 0.07,no keep same with original.
Comment 7 zhengfan 2012-09-04 08:11:20 UTC
Sorry for the missing comments:
MS Word only support the border shadow with the same width of the borders, which means we can not specify the width of border shadow freely in MS word document as we can do in AOO.

So the specified width of border shadow in AOO, will be lost after saving into MS word document.

Thanks a lot, and for you reference, DuJing.
Comment 8 Du Jing 2012-09-04 08:45:32 UTC
Thanks for your explain,close the defect~
Comment 9 Shenfeng Liu 2012-10-10 06:46:23 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.
Comment 10 anistenis 2013-05-21 11:16:02 UTC
I still can reproduce this bug in AOO400m1(Build:9700)  -  Rev. 1479897.
In fact, the background disappears after saving as a .doc the attached document.