Issue 120654 - [From Symphony]Number range variable filed shows in AOO
[From Symphony]Number range variable filed shows in AOO
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: kang jian
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 05:39 UTC by Yan Ji
Modified: 2012-10-10 06:49 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample (119.00 KB, application/msword)
2012-08-22 05:39 UTC, Yan Ji
no flags Details
snapshot (79.56 KB, image/png)
2012-08-22 05:40 UTC, Yan Ji
no flags Details
Fix for Number range variable filed shows in AOO. (623 bytes, application/octet-stream)
2012-08-24 03:25 UTC, kang jian
jane73_kang: review?
Details

Note You need to log in before you can comment on or make changes to this issue.
Description Yan Ji 2012-08-22 05:39:33 UTC
Created attachment 79055 [details]
sample

Build: AOO 3.4.1 rev. 1372282
OS: All
Steps:
1. Load sample file in AOO
2. Go to page 6

Defect: There is number "1" exist in some section which doesn't show in MS Office
Comment 1 Yan Ji 2012-08-22 05:40:56 UTC
Created attachment 79056 [details]
snapshot
Comment 2 kang jian 2012-08-24 03:25:47 UTC
Created attachment 79111 [details]
Fix for Number range variable filed shows in AOO.

Root cause:
Current in OOO, don't deal with the flag \h of seq field.\h define in MS office is hiden the field result.

Solution:
Add determine statements to hide the Number Range field in OOO.

UT:

Test on the doc files that have seq fields with \h, \c, \r flag.
Comment 3 Jian Hong Cheng 2012-08-29 05:34:33 UTC
Reviewed and committed with revision:1378443
Comment 4 Jian Hong Cheng 2012-08-29 06:09:17 UTC
Reference 119405
Comment 5 Du Jing 2012-09-04 06:51:30 UTC
verified on the build AOO3.5_r1380171
Comment 6 Shenfeng Liu 2012-10-10 06:49:10 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.